Jump to content

Pandora Timeshifting App: Main Discussion Thread


Recommended Posts

Also, when I change the settings in pandora.jar (using the Firefox browser) and click "save", I don't see any files modified with the current Pandora directory (or the subs). Is this supposed to save changes (such as default directory, autosurf) to a config file (default.properties?)?

It saves the settings in a cookie, not a file. So that doesn't surprise me. ;)

A lot of these recent space of problems sounds almost as if the files aren't being unzipped to the proper directory.

If you are RUNNING PandorasJar and try to overwrite the jar file it will cause an error and it won't get upgraded.

Try unzipping to a 'clean' directory and then running it from there. If that works then copy it over to your normal installation directory. (This is a good practice anyways since you don't want to accidently overwrite properties files and such by accident.)

Try renaming your pandora.jar file to pandora_old.jar before copying the new files into the installation.

Link to post
Share on other sites
  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Somewhere along the line you've gotten an OLD pandoraGrabber.html file.

Try installing to a clean directory and if it works, just copy everything over to your normal installation.

That's the ticket! Thanks for the tip. BTW...props to all involved in this project, it provides a good diversion for my music obsession. :mrgreen:

Link to post
Share on other sites

wrong filenames:

does anybody else have the problems (my last post) with the incorrect filenames ? I've tested it and it also happens if the plugtemp folder is complete empty !

Last time it happens after 6 recorded mp3 files ? the last one was the same as no. 5 ?

What else could it be if no one have similar probs .... ???

Link to post
Share on other sites

Okay...started from scratch. Went back to the C: and created a new Pandora directory. Empty. Did NOT remove jacob.dll from the sys32 directory (assume that is still good). Downloaded the recent version pandoras-jar-beta.4.zip and extrated all folders/files to c:pandora. It's in. I then run pandora.jar right from c:pandora and it opens the java window and says ready to rip.

I open Firefox 1.5.0.1 and open http:localhost. I get 5 "localhost connected to server" messages in the java window, and a new version of Pandora opens in Firefox (my two-day old one was definitely different). Pandora does not run in Firefox. The box below the mythos2006 picture is blank (white). I disabled adblock to make sure that it was not blocked. Right clicked the white box and says I have Flash 8,0,24,0 installed.

I go to Pandora's site and Pandora works without a glitch. Comes right up.

So why isn't the Flash working for me in PandoraJar's localhost window?

Thanks in advance...again.

Link to post
Share on other sites

@tortdog

I may have misread but are you saying that you have pandora jar 4? I only ask because the latest is pandora 7.3.1. The reason why pandor jar 4 would not work may be because it is referencing the wrong flash version in the grabber file. You can manually edit it to the correct version but you really need to have pandora 7.3.1.

http://ww2.wildandbad.com:8181/article/pandoras-jar

Hope that helps.

Link to post
Share on other sites
Guest t3chn0b0y
Skins Pack 1

I was inspired by moonlit's awesome wallpapers to create a new set of skins for Pandora's Jar.

Someones been busy.busy,busy... thanx for the great work..

Link to post
Share on other sites

FIXED lingering firefox wrong browser couldn't get mp3 problem.

Accidentally installed Flash 9. Followed the previously links to uninstall and re-install (Flash 8); however, the install link was for Flash 9 so it wouldn't work.

Flash 8 install was hard to find: http://www.adobe.com/cfusion/knowledgebase...cfm?id=tn_14266

Installed 8 after uninstalling 9 and let it run for a while. Same error at first, but it eventually corrected and I'm back in biz.

Pershiate all the others who've helped on this forum and hope this helps someone else

Link to post
Share on other sites

Thanks for the help to date, but I think I'm going to give it a rest. I did go

back and try a clean install using:

http://ww2.wildandbad.com:8181/article/pandoras-jar

That refers you to a page that states the downloads are 7.3, but downloads

as 7.2 (you can see that in the link itself as well, obviously). I'm not sure if

that is downloading the latest 7.3 or 7.2 (knowing that 7.3 had problems

with the 7.2 jar being used in 7.3 to "patch" it).

Meanwhile, at http://www.hak5.org/forums/viewtopic.php?t=983 it says the

latest jar is http://comicnut.speedxs.nl/pandoras-jar-beta.4.zip (what I

referred to as 7.4) but since it's beta, maybe it's not stable. That's the one

in which the flash doesn't work for me, but the interface matches the

"latest" that others have posted on this thread.

Meanwhile, I downloaded "The latest stable version (BETA version 7.3.1)" at

http://wildandbad.com/pandora.beta.7.3.zip. That was the last one that

worked on my machine at one time. Now it doesn't, telling me to make sure

I'm running Firefox (and of course I am...why would I even go near

Explorer).

Anywho, now I'm getting some errors like:

function m(b){return b!=null?'"'+b+'"':'""'}

function B(b){if(typeof encodeURIComponent=="function"){return

encodeURIComponent(b)}else{return escape(b)}}

function c(b,a){if(a){window.google_ad_url+="&"+b+"="+a}}

function f(b,a){if(a){c(b,B(a))}}

function l(b,a,d){if(a&&typeof

That goes on for quite a while...

Who knows where that came from. Think I'm going to take a

breather...maybe wait for another version that might work a little better.

Thanks for the patience, though. If there are any thoughts, I am all ears.

Link to post
Share on other sites
Guest t3chn0b0y

unable to retrieve bio from last.fm: Script '(function(){ function m(b){return b!=null?'"'+b+'"':'""'} function B(b){if(typeof encodeURIComponent=="function"){return encodeURIComponent(b)}else{return escape(b)}} function c(b,a){if(a){window.google_ad_url+="&"+b+"="+a}} function f(b,a){if(a){c(b,B(a))}} function l(b,a,d){if(a&&typeof a=="object"){a=a[d%a.length]}c("color_"+b,a)} function D(b,a){var d=b.screen;var g=navigator.javaEnabled();var e=-a.getTimezoneOffset();if(d){c("u_h",d.height);c("u_w",d.width);c("u_ah",d.availHeight);c("u_aw",d.availWidth);c("u_cd",d.colorDepth)}c("u_tz",e);c("u_his",history.length);c("u_java",g);if(navigator.plugins){c("u_nplug",navigator.plugins.length)}if(navigator.mimeTypes){c("u_nmime",navigator.mimeTypes.length)}} function y(b){b=b.toLowerCase();if(b.substring(0,3)!="ca-"){b="ca-"+b}return b} function G(b,a,d){d=d.substring(0,1000);d=d.replace(/%w?$/,"");if(b.google_ad_output=="js"&&(b.google_ad_request_done||b.google_radlink_request_done)){a.write('")}}else if(b.google_ad_output=="textlink"){a.write('

the above happens when using the new skins and when retrieving info from last.fm

Link to post
Share on other sites
Skins Pack 1

I was inspired by moonlit's awesome wallpapers to create a new set of skins for Pandora's Jar.

trying to steal my thunder?!

hahah kidding man, good job. im takin my sweet ass time with the new skin.

glad to see some more skins floating around. thanks for ALL of your hard work!

Link to post
Share on other sites

I read that someone let the program just run for a bit and it eventually started

to work. So, hey. Why not. I did the same thing. It started out with the same

errors. Then after about 20 minutes it is now fixed.It's saving the MP3's and

the errors generated in the JAR window have disappeared (only "localhost

conntected to server" showing up).

The only reason I'm writing this is if it's useful to the developers. I used to

program (been a while) and self-fixing bugs sounds impossible. But, there it is.

Link to post
Share on other sites
I read that someone let the program just run for a bit and it eventually started

to work. So, hey. Why not. I did the same thing. It started out with the same

errors. Then after about 20 minutes it is now fixed.It's saving the MP3's and

the errors generated in the JAR window have disappeared (only "localhost

conntected to server" showing up).

The only reason I'm writing this is if it's useful to the developers. I used to

program (been a while) and self-fixing bugs sounds impossible. But, there it is.

same for me. also if you just restart it a couple of times...

ALL DONE... presenting "digital junky"

digital%20junky.JPG

http://webpages.charter.net/sb76117/skins/...tal%20junky.zip

Link to post
Share on other sites
Guest t3chn0b0y
shit!!! i fucked it up. it says "satisfy your technolust" instead of "trust your technolust"

fuck it... its about gettin the music. satisfy is better.

I grab alot of techno so it works for me :D

Link to post
Share on other sites
Guest t3chn0b0y

Is there anyway to pass parameters... let me be a bit more specific

something like pandora %artist or pandora %song then when loading

up it will create a station based on that artist or song.

i know i can do it when loading up pandora by itself in a browser

but now that feature is not available when running the jar..

http://www.pandora.com/?searchFilter=artis...;search=%artist

http://www.pandora.com/searchFilter=song&search=%song

im using bblean mod and sometimes litestep and i have some command windows i can use to pass parm with.. just a thought anyway.. just another hater of the heavy windows desktop.. minimalizing with complexity.. ;)

Link to post
Share on other sites

Here's a bug (I think) for someone to look into. In Mp3Processor.java, in function joinMp3s, the accumulated file array might be wrong. The "for" loop exits with a 'LOG.debug("no more mp3 found in dir"); return;' when a non-directory, non-mp3, non-recent file is found. If that happens before the plugtmp (or plugtmp-x) directory is processed in the "for" loop, the function doesn't recurse and process that directory. That can be seen in the log file output when the same file is saved multiple times with the wrong filename and tagging. The determination of "non-recent" is in isFileRecent, where it appears that "recent" is within 3 hours. When you delete the plugtmp (and/or plugtmp-x) directory and start clean, you can see the problem happen 3 hours into the running of the program.

Until fixed, I think stopping the program, cleaning up, restarting, should eliminate that problem.

Comments? Am I all wet?

Link to post
Share on other sites
Here's a bug (I think) for someone to look into. In Mp3Processor.java, in function joinMp3s, the accumulated file array might be wrong. The "for" loop exits with a 'LOG.debug("no more mp3 found in dir"); return;' when a non-directory, non-mp3, non-recent file is found. If that happens before the plugtmp (or plugtmp-x) directory is processed in the "for" loop, the function doesn't recurse and process that directory. That can be seen in the log file output when the same file is saved multiple times with the wrong filename and tagging. The determination of "non-recent" is in isFileRecent, where it appears that "recent" is within 3 hours. When you delete the plugtmp (and/or plugtmp-x) directory and start clean, you can see the problem happen 3 hours into the running of the program.

Until fixed, I think stopping the program, cleaning up, restarting, should eliminate that problem.

Comments? Am I all wet?

Actually that would explain a lot.

What if it deleted the files once it moved them? I mean really if it can't move them while they are playing then it won't remove anything being played, right?

Link to post
Share on other sites

I just discoverd Pandora and it's awesome. The instructions were perfect and it works beautifully. My question is, is there a way to have it just dump the MP3s into one common directory as oppose to creating a new sub-directory for every artist?

Link to post
Share on other sites
eh all

i just dl the pandoras jar /paste in C: then use the command promp and got the blue screen

but when i type in http://localhost:8085 . the page does not load compleatly

i can see a few text boxes , one says "abort" other ones on the bottom say user name and pw

nothing seems to load

i do have firefox

but the pandoras jar says "unable to rip mp3 unable to find file make sure ou have pandora running in a firfox browser"

any info ?

thanks ~STABB

!''#'~@!!! anyone know how I move indivdual posts?

Link to post
Share on other sites
I'm having a problem with my install. The app loads, but the pandora player doesn't. I followed the install instructions 100%. though i had to re-install flash 8.

You downloaded the wrong version. Scroll down the N00bs guide to the SECOND set of download and install instructions and try again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...