Jump to content

Pandora Timeshifting App: Main Discussion Thread


Recommended Posts

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Hi,

very fine... I've got this message... up to your link...

Forbidden

You don't have permission to access /pandora.alpha.6.zip on this server.

Apache/1.3.33 Server at wildandbad.com Port 80

CB

Whoops! My Bad. A Security measure to prevent upload and execute viruses. It is allowed now.

Link to post
Share on other sites

Hi,

nothing works at all anymore ... Pandora changed the player ???

at first)

I've tried to work with the alpha6 but it didn't stream anything. By the way in beta4 the mp3's could be found in the folder "mp3". Where do I've to look for the recoreded mp3´s ????

second)

while trying to work with alpha6 Pandora stopped with the message, your Player is no more actual. I've stopped this and tried again... The pandora player did not start again anymore....

I think it belongs to this little fact....

pandoramsg060610.jpg

now there are ready....

a totally confused baby....

Link to post
Share on other sites

It is very easy to correct the problem that occurs since the update of Pandora.

1) In the pandoragrabber.html file, find

"https://www.pandora.com:443/radio/tuner_6_9_0_4.swf"

2) Change it into :

"https://www.pandora.com:443/radio/tuner_7_0_0_0.swf"

It will work again without any problem !

Link to post
Share on other sites
It is very easy to correct the problem that occurs since the update of Pandora.

1) In the pandoragrabber.html file, find

"https://www.pandora.com:443/radio/tuner_6_9_0_4.swf"

2) Change it into :

"https://www.pandora.com:443/radio/tuner_7_0_0_0.swf"

It will work again without any problem !

worked like a champ. The original string is in the file twice just as a future FYI.

Link to post
Share on other sites

hi,

your right ... that works...

but where goes the mp3 ?

I'am not able to localize them.... sorry...

the logs says.... the folders after desktop ... I couldn't find....

ripped file to: C:Documents and SettingsAll UsersDesktopdownloadsMusicmp3MrDave RadioBlue Man GroupBlue Man Group-Sing Along (feat Dave Matthews).mp3

yea baby!!!

Link to post
Share on other sites
It is very easy to correct the problem that occurs since the update of Pandora.

1) In the pandoragrabber.html file, find

"https://www.pandora.com:443/radio/tuner_6_9_0_4.swf"

2) Change it into :

"https://www.pandora.com:443/radio/tuner_7_0_0_0.swf"

It will work again without any problem !

Also note that the tuner_6_9_0_4.swf string occurs twice in the pandoragrabber.html file. You probably should change both. Changing just the first occurance in the <PARAM> tag didn't fix it for me (maybe because of a browser setting... not sure). So, at least in some circumstances you must also make the change in the <EMBED> tag.

Link to post
Share on other sites

Hi Folks,

using: alpha6...

the properities file look like this...

mp3.archive.path=C:/pandora/mp3/

Everything works but I couldn't found the mp3 files...

The log:

again this message ...

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

Link to post
Share on other sites
I've uploaded a new pandora.jar to my server. It's got that useless Long.parseLong() call removed which was the cause for the "String index out of bounds -1" problem people reported.

Please give it a go and tell me how she fares.

I downloaded this, adjusted the HTML to use "https://www.pandora.com:443/radio/tuner_7_0_0_0.swf". and am still having a problem.

The tag information is loaded OK but the mp3 file never copies - no error, no timeout , no list of messages in the Jar Window. Rebooting seems to make no difference.

Link to post
Share on other sites

It is very strange : everything was working for me. I put the 6th version of the pandora.jar file and after I didn't work anymore.

I've replaced everything as before and it works again.

Is the 6th version a bad version ?

Here is a part of the log with 6th version

INFO Thread-2 server.Server - processing url: GET /radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled HTTP/1.1

INFO Thread-2 servlet.ProcessAction - processing static request. path: GET /radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled HTTP/1.1

INFO Thread-2 servlet.ProcessAction - path = radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled

INFO Thread-2 server.Server - Invalid request: radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled

INFO Thread-2 server.Server - localhost connected to server.

INFO Thread-2 server.Server - handling request

INFO Thread-2 server.Server - processing url: GET /radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled HTTP/1.1

INFO Thread-2 servlet.ProcessAction - processing static request. path: GET /radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled HTTP/1.1

INFO Thread-2 servlet.ProcessAction - path = radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled

INFO Thread-2 server.Server - Invalid request: radio/TUNER_IGNORE/v1?lid=2109233&method=audioDownloadCancelled

Link to post
Share on other sites
hi,

your right ... that works...

but where goes the mp3 ?

I'am not able to localize them.... sorry...

the logs says.... the folders after desktop ... I couldn't find....

ripped file to: C:Documents and SettingsAll UsersDesktopdownloadsMusicmp3MrDave RadioBlue Man GroupBlue Man Group-Sing Along (feat Dave Matthews).mp3

yea baby!!!

Um, yes. My fault again, I'm afraid. In Pandroa's Jar Folder you will find a file called default.properties. Edit it to change the path for your files to be sent to.

#uncomment the following line to set your preferred storage dir

#u can change at at runtime if u want

mp3.archive.path=C:/Documents and Settings/All Users/Desktop/downloads/Music

Or comment out the last line (with a # at the beginning of the line) to have them saved in the Pandora folder by default.

Link to post
Share on other sites

Hey guys, any idea what's going on here?

I can get the player to load (after changing the pandoraGrabber.html file as noted above). And music plays, but it won't rip the files.

I get the error message shown in this screenshot:

pandorajar4xm.jpg

Thanks!

Link to post
Share on other sites

I'm unable to rip ATM too.

INFO Thread-2 servlet.ProcessAction - handling mp3 request

INFO Thread-2 util.Mp3Processor - locating mp3

INFO Thread-2 server.Server - unable to rip MP3

java.lang.NullPointerException

    at java.util.Arrays.sort(Unknown Source)

    at util.Mp3Processor.sortFilesByMostRecent(Mp3Processor.java:154)

    at util.Mp3Processor.findUserTmpDir(Mp3Processor.java:139)

    at util.Mp3Processor.findCurrentMP3(Mp3Processor.java:25)

    at servlet.ProcessAction.handleMP3Request(ProcessAction.java:30)

    at server.Server.handleHTTPRequest(Server.java:110)

    at server.Server.run(Server.java:83)

INFO Thread-2 server.Server - unable to rip MP3 null

Any ideas?

Link to post
Share on other sites

@the_Rat: You've got an old pandora.jar file, otherwise there would've been a longer trace before this. Grab a new one here.

@Extreme_One: The program expects to see a number of files in the %TEMP% directory. According to the trace the value in %TEMP% isn't the name of a directory on your system.

Link to post
Share on other sites

Something has definately changed...

1: My PandorasJar.log file is flooded with this message:

INFO Thread-2 server.Server - handling request

INFO Thread-2 server.Server - processing url: GET /process?action=grab&amp;artist=--Snip--on&amp;_= HTTP/1.1

INFO Thread-2 servlet.ProcessAction - handling mp3 request

INFO Thread-2 util.Mp3Processor - locating mp3

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

My Temp File looks like this (note the file names)

pandoraFiles060610-1.jpg

and that provocative plugtmp file has this in it:

My Temp File looks like this (note the file names)

pandoraFiles060610-2.jpg

The Java stuff isn't my speciality...maybe mr Cooper can bug this out.

Link to post
Share on other sites

Those 2 images on wildandbad.com aren't coming in (server not responding) so I can't see what's going on there.

The access file not found part comes from Mp3Processor.java line 39. You only get this because of the exception that is thrown on line 104 (the identical exception that is thrown on line 148 isn't inside the try-catch block that is logging this error).

So, allow me to explain the events leading up to line 104 in the getAccessFile method:

The files array is filled with all regular files whose name starts with 'plugtmp' which are contained inside the directory that is being denoted by %TEMP% sorted by modification date so that the last modified file comes first in the array.

We then enter the for loop on line 85... (this is where I'm starting to get that ooooh, SHIT! feeling I'm sure you're all familiar with aswell)

First thing that happens is that all files in that array with a name shorter than 11 characters (see? DAMNIT!) get discarded. There's about a.... 100% chance this is what's biting those who are having issues.

We grab the top 2 entries of what remains in the array. If there aren't 2 entries left anymore, that exception gets thrown.

So, I'm confident this is another issue found and easily fixed. There's no sane explanation for the length>10 check anymore (was built in earlier as a fix for something that has since been removed).

Line removed plus a little cleanup (try-catch block in the for-loop is useless. My for-loop currently only contains the if/else). Grab the new pandora.jar from here and this problem should cease to exist.

Filesize of this version: 92858 bytes

If this looks like a winner I'm gonna wrap this up in a beta 7 (I think we're up to 7 right? Saw a beta 5 and 6 floating around) release, and start including build numbers or something in the program so people can tell which version they're running. I wouldn't be at all surprised if people are puzzled by that one right now.

Link to post
Share on other sites
@@Extreme_One: The program expects to see a number of files in the %TEMP% directory. According to the trace the value in %TEMP% isn't the name of a directory on your system.

Well the files are definately in my TEMP directory so the app is failing to find them...

Do I need to add a SET TEMP="drivepathdirectory" so that my TEMP folder can be found?

If so can somebody please post the exact syntax here (XP's default temp directory) as I have tried to do that by adding a line in the batch file and so far I've failed :oops:

Unless the latest version fixes this issue for me... I'll test it when I get home later.

Link to post
Share on other sites
Well the files are definately in my TEMP directory so the app is failing to find them...

Do I need to add a SET TEMP="drivepathdirectory" so that my TEMP folder can be found?

If so can somebody please post the exact syntax here (XP's default temp directory) as I have tried to do that by adding a line in the batch file and so far I've failed :oops:

The correct syntax is indeed SET TEMP="<path to temp dir>". As a test, open a DOS box, run the command and then run dir %TEMP%. If you get a listing from your TEMP folder, things should be okay.

Unless the latest version fixes this issue for me... I'll test it when I get home later.

This newer version won't fix your particular problem, but you'll probably want it anyways.

Link to post
Share on other sites
Is there any way to change the folder structure ? I'd like to have only 1 storage folder with *.mp3 nothing else (no station info etc.) ?

To remove the station's name, the easiest way to do is to remove your email from the field "Pandora username". It won't use the station's name anymore.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...