Jump to content

Utorrent killing web surfing...


bmanice
 Share

Recommended Posts

After i have utorrent open for awhile, 99% of the time when i close uttorent, my internet browsing is slow as SHIT, sometimes non-existent until i restart my puter. Is there any tweaks i should do to Utorrent, TCP settings, or my ddwrt wrt54g box?

btw i have my DL/UL settings at 750 kB/s / 50 kB/s on my basic cable connection.... TCP reicieve window at 128480... window scaling...no time-stamping...selective ACKs...TTL @ 64... max duplicate ACK's 2... no black hole detection.... path MTU discovery....

dont know if that info is needed....

thanks in advance guys...

Link to comment
Share on other sites

What I do is open(port worward) from my router to my pc and tell utorrent to use the specific port forwarded port in the router. When I am donw, I go back into the router and turn it off, otherwise you get flooded with packets that can cause a sort of dos, but if you have decent firewall up, it should reject them. I woudl start with the router settings and making sure your only receiveing for the port you specify in utorrent and vice versa. If you have a firewall with a log, check it bfore during and after your utorrent use. You will see all the requests after utorrent is closed are still trying to get to your pc, so this may be killing your connections or someone from utorrent is trying to get in or flood you. I have seen this problem mainly of fake torrents that start quick and then nose dive only flooding me with connections from all the same ip rane, ex: xx.xx.xx.1-xx.xx.xx.25

Usually there are only a handfull with about 10 or so consecutive ip addresses(turn off domain name res to see just the ip addresses and not the names) in use which can be blocked on the firewall side of things. This is also good as it blocks them from being able to send you data during the torrent download process and has actually increased my throughput when downloading torrents by blocking some of these addresses.

Check your logs after you clost utorrent, and you will see what I mean about the flood of incoming requests. Eventually the tracker will remove you when it does not get any packets from you for a long time, and the requests stop, unless they use a cached torrent file that has you listed as one of the people in the file.

Link to comment
Share on other sites

I'm guessing that if you crank up wireshark after you've closed utorrent you'll see a shed load of incoming connection attempts. Closing the port on your gateway should help this, if it is the case. I would have a look-see with wireshark anyway, just to see what is happening. Do the following also:

1: open up your dd-wrt gui, go to the Administration tab, then scroll down to "IP Filter Settings (adjust these for P2P)", and set it to 4096, 90, 90. By default your router will remember each connection it handles for fecking days (for the SPI). By setting it to allow more connections, but forget them after 90 seconds of inactivity it should speed things up.

2: Go to "Applications & Gaming", then QoS. RTFM, then setup QoS to priorities http, https, dns and so forth. This will mean that your torrent client has all the bandwidth until you request a web page, at which point your web page will load faster and the torrent will scale back. This will mean your connection is slightly less fast, but it should also mean that latency is improved. I like this trade off myself.

3: Make sure your using a static LAN address, bind utorrent to it, and setup port forwarding correctly.

Link to comment
Share on other sites

I'm guessing that if you crank up wireshark after you've closed utorrent you'll see a shed load of incoming connection attempts. Closing the port on your gateway should help this, if it is the case. I would have a look-see with wireshark anyway, just to see what is happening. Do the following also:

1: open up your dd-wrt gui, go to the Administration tab, then scroll down to "IP Filter Settings (adjust these for P2P)", and set it to 4096, 90, 90. By default your router will remember each connection it handles for fecking days (for the SPI). By setting it to allow more connections, but forget them after 90 seconds of inactivity it should speed things up.

2: Go to "Applications & Gaming", then QoS. RTFM, then setup QoS to priorities http, https, dns and so forth. This will mean that your torrent client has all the bandwidth until you request a web page, at which point your web page will load faster and the torrent will scale back. This will mean your connection is slightly less fast, but it should also mean that latency is improved. I like this trade off myself.

3: Make sure your using a static LAN address, bind utorrent to it, and setup port forwarding correctly.

Thanks for the info VaKo, you bring up some interesting things i havent thought about yet, mainly with the QoS, pretty good idea...

I set my max connections to 4096 and times to 90 seconds.... inproved performance of my web browsing tremendously, and still get nice speed with utorrent... now i need to figure out why the hell i cant get it to port forward lol

Link to comment
Share on other sites

I'm guessing that if you crank up wireshark after you've closed utorrent you'll see a shed load of incoming connection attempts. Closing the port on your gateway should help this, if it is the case. I would have a look-see with wireshark anyway, just to see what is happening. Do the following also:

1: open up your dd-wrt gui, go to the Administration tab, then scroll down to "IP Filter Settings (adjust these for P2P)", and set it to 4096, 90, 90. By default your router will remember each connection it handles for fecking days (for the SPI). By setting it to allow more connections, but forget them after 90 seconds of inactivity it should speed things up.

2: Go to "Applications & Gaming", then QoS. RTFM, then setup QoS to priorities http, https, dns and so forth. This will mean that your torrent client has all the bandwidth until you request a web page, at which point your web page will load faster and the torrent will scale back. This will mean your connection is slightly less fast, but it should also mean that latency is improved. I like this trade off myself.

3: Make sure your using a static LAN address, bind utorrent to it, and setup port forwarding correctly.

Thanks for the info VaKo, you bring up some interesting things i havent thought about yet, mainly with the QoS, pretty good idea...

I set my max connections to 4096 and times to 90 seconds.... inproved performance of my web browsing tremendously, and still get nice speed with utorrent... now i need to figure out why the hell i cant get it to port forward lol

Firewall blocking the ports?

Link to comment
Share on other sites

After i have utorrent open for awhile, 99% of the time when i close uttorent, my internet browsing is slow as SHIT, sometimes non-existent until i restart my puter. Is there any tweaks i should do to Utorrent, TCP settings, or my ddwrt wrt54g box?

btw i have my DL/UL settings at 750 kB/s / 50 kB/s on my basic cable connection.... TCP reicieve window at 128480... window scaling...no time-stamping...selective ACKs...TTL @ 64... max duplicate ACK's 2... no black hole detection.... path MTU discovery....

dont know if that info is needed....

thanks in advance guys...

Usually what many do is to set "Bandwidth Allocation" to the lowest priority for Utorrent, this normally shan't lower your Download speed very much.

i cant get port forwarding to work... tried everything, but the port forward test utorrent uses wont connect...??  worked fine yesterday...

I suggest this site - http://portforward.com/

Look for your modem/router model there and follow the detailed pictures layed out for you in the instructions. If you have trouble with this feel free to ask. Generally you would connect to your Modem/Router by finding out the "Default Gateway" then inputing the address to your URL bar through your browser. To do this simply -

Click on the "Start" button, hit "Run", input into run "cmd" without the quotation marks and manually type "ipconfig" without the quotes. The numbers beside the text "Default Gateway" will be the address of your router/modem. I do not know the model of your specific router/modem so please use portforward.com.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...