Jump to content

Problem Installing Mac OS (8.5) on blank hard drive.


siriusfox
 Share

Recommended Posts

Well, let us see if the abilities of the community here are as spectacular as the show describes.

I have a 1st Gen, Rev B, iMac G3 233MHz 96MB RAM.  I also have the System Install and Restore disks that came with the machine when I bought it way back in the 90's.

The machine had a working 4GB hard drive in it.  For those of you who remember or have ever used the classic Mac OS, it is not fast, it has never been fast, and that machine is no exception.  My goal is to turn it into a thin client, or a lightweight install of Linux.  However, I wanted to retain a copy of the Mac OS, as the primary users of this machine would be somewhat computer inept, shall we say.  To do such an install I would need a bigger hard drive, so I pulled the 4GB out, and slapped in an old 10GB I had lying around.

Every guide I had read said install Mac OS first.  Having installed linux systems on my PC before, I thought no big deal, I'll do a clean install, run the updates, and then shrink the drive and install Debian on this thing.

So, I booted up off of the Mac OS 8. 5 iMac System Install CD, and used the "Disk Setup" tool to partition the drive, and then the installer on the CD to install the operating system.  No errors come up, no problems occur.  After the install still in the live cd mode, I can see files on the disk, I can read and write to the disk no problem.

However, when I remove the disk and reboot, I get the blinking question mark of DOOM! I've tried a clean install of JUST debian all default settings, and I get the same problem as I do with the Mac OS.  The problem as I believe it is that something is being partitioned incorrectly, or something in OpenFirmware is being missconfigured.

Now, suggestions, ideas, solutions, anything.  I have an x86PC running Linux (Not Windows), if anyone has tools that only offer x86 builds.

-Siriusfox

[Edit; I didn't see the Water Cooler Questions area. Can someone move me over there please?]

Link to comment
Share on other sites

If you are trying to install an x86 Linux Distro, It will not work. You would have to get a PPC(PowerPC) Linux Distro.

Also, Tell the Distro to NOT install a Boot Loader. Use the OS 8.5 Boot loader as the MacOS dosent work with anything else.

Hope that Helps.

Link to comment
Share on other sites

Allow me to explain a little better.

The Linux install CD's I have, are the PPC based System Rescue CD, currently at version 0.2.0 for PPC, and Debian Etch PPC.

The hardware is as I said before a 1st Gen iMac G3.

For whatever reason, a generic install of the Mac OS, or of Debian etch will not boot up. The install goes with no errors whatsoever, but I get the blinking question mark.

The problem lies with either the Open Firmware configuration, or the bootloader configuration of both Linux and the Mac OS.

Link to comment
Share on other sites

I can boot and install with the debian CD. After all of the configuration I tried using the expert boot command, I said I'll reduce the varibles and do a generic install.

I used the defaults for everything, and the install worked fine from the CD. However, I cannot boot into the install.

I'm using the boot loader on the install CD. The problem is, it never gets to the PPC Yaboot boot loader that debian has. It stops prior to that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...