Jump to content

routers communicating WIRE -LESS-LY


tanda333
 Share

Recommended Posts

i have a wrt54g connected to internet, it broadcasts my internet to everything, it HAS TO REMAIN INTACT, now i cant run a wire to some of my comps dure to walls im n ot allowed to cut (not my house ATM) so what im going to do is take another wireless router (i believ its an airlink superG model) and disable dhcp on it and have it communicate with the first router so that i can plug my ethernet cables into the second router.

how do i get them to communicate?

edit: the airlink is an  ar430w

Link to comment
Share on other sites

Configure the IP address of the secondary router to be in the same subnet as the primary router, but out of the range of the DHCP server in the primary router. For instance DHCP server addresses 192.168.0.2 through 192.168.0.100, I'd assign the secondary router 192.168.0.254 as it's IP address.

Disable the DHCP server in the secondary router.

Setup the wireless section just the way you would if it was the primary router.

Connect from the primary router's LAN port to one of the LAN ports on the secondary router. If there is no uplink port and neither of the routers have auto-sensing ports, use a cross-over cable. Leave the WAN port unconnected!

or

check through the Airlink's configuration and see if it has any option to put it in bridge mode or client mode.

good luck    8-)

Link to comment
Share on other sites

Wireless distribution system?

http://en.wikipedia.org/wiki/Wireless_Distribution_System

Would seem to cover all the bases... Or, you can set the WRT54G to connect to the other ar430w as a wireless client with the help of DD-WRT. I'm not sure which will suit you best as I only know that these things exist, its not something I've tried.

Link to comment
Share on other sites

thx for the help ill look to see if there is a bridge mode, client mode or access poitn mode....... now do both routers have to be able to do the client, bride mode, or AP mode? or just the one not running DHCP and the one that is NOT connected to the internet.

the biggest question is i have been have problems connecting to the second router through a cat5 cable.....ive gotten it to work once, but would appreciate someone tellingme the steps i stumbled upon earlier

edit: also, another thing, ive seen on a laptop a function that says ad-hoc network (pc to pc) i presume its saying a comp with internet access can jump through comps without if they all have wireless cards to give a comp without internet access access to the first comps (if it shares internet)

ALSO: I CANT USE WIRES TO CONNECT EM

if i coulda, i would have

Link to comment
Share on other sites

Ad-hoc is PC to PC only, although you could look into ICS if your operating on a shoe string. As for the router to router with cat5, just hook the 2nd routers wan socket to a lan socket on the 1st router, set the 1st router to function as a gateway and the 2nd as a router, set a static IP and enable DHCP forwarding in the 2nd router. Should work ok-ish with a bit of trial and error.

Link to comment
Share on other sites

no, sorry, by connecting to the second router by cat5 cable i was referring to getting my computer to edit the settings in it........ i cant seem to get my comp to connect to it. its one of those routers that doesnt like to work without something in the WAN port

Link to comment
Share on other sites

  • 1 month later...

Hey guys I'm trying to setup WDS. I have of course a wrt54gs ver.4 running DD-WRT and a Buffalo WYR-G54. I kinda got the idea how to configure the wrt54gs, but not so sure how to get the buffalo to connect to it wirelessly. Any suggestions? I'm currently trying to get it working reading this site now, hopefully it will help.

http://www.dd-wrt.com/wiki/index.php/WDS_L...F_WRT54GL_boxes

The options in the buffalo seem limited I wish I could run DD-WRT on this one:(

Link to comment
Share on other sites

I was in a very similar situation recently (only I had 2 wrt54g's).  What you need to do is set up your buffalo set up as the access point (make sure DHCP is on).  Then go to your wrt54g which hopefully by now you have dd-wrt on.  Open it up (the default username is root password admin), now turn off the DHCP server and change the default IP address to 192.168.1.2 .  Now open up the wireless tab.  Change the mode to Client-Bridge.  Type in the correct SSID and any security information (WEP, WPA, etc) (excluding mac address filtering I will get to that later).  Now open up the status page.  Under status click on the wireless tab and click on site survey.  In site survey find the network you want to join and click join.

If you have MAC filtering enabled, you don't do anything with your bridge, you open up your access point and under the MAC filter list type in the 3 MAC addresses that are associated with your wireless router.  To find them just go back to the status page on you bridge, there will be a wired MAC a wireless MAC, and a general MAC, if you don't enter all of those in you will not successfully be able to join the network (I know from experience).  Generally MAC filtering just gets in the way of this AP Bridge setup.  I hope you found this helpful, it worked great for me just ask any other problems with it you have.  I promise you this will work.

Link to comment
Share on other sites

@ SmoothCriminal,

Wow... I didn't expect anybody to reply back on this. I really was beginning to think that it would not work, because the options are so limited in the Buffalo. I gotta get to bed right now, but tomorrow as soon as I get home from work I will try this and definitely post back results. Thanks alot man, very well explained and I really appreciate it:)

Link to comment
Share on other sites

  • 2 weeks later...

@ SmoothCriminal

I finally tried this out. It took me awhile, because I was just gonna get another wrt54g, because I don't like the fact that the buffalo can't disable SSID broadcast. I tried it out, but for some reason the linksys wouldn't stay connected to the buffalo. Then for some reason when I changed the wireless mode I didn't see any option to disable the dhcp server in the linksys, but it said it was disabled. The linksys still held a good wan ip, but lost wan dns servers and I had no internet access at least by domain name, I didn't try by ip.

The worst part was I decided to just wait and get another wrt54g, but when i changed the wireless mode back to AP the router would not grab a ip from the modem. I had to reset it back to factory defaults:( Then re-configure it again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...