Jump to content

Lan Turtle and Cloud C2

Go to solution Solved by dark_pyrro,

Recommended Posts

Hello so i have recently bought a keycrock and a lan turtle the keycrock is after a day of asking questions etc ready but now im stuck again this time with the Lan turtle so i did basicly everything said as in the setup video(Setting up Cloud C2 as a service on boot & exfiltrating loot with a LAN Turtle - Hak5 2703) but the problem is as soon as i ssh into the Lan turtle and type the (as in the video) C2 command or any command in the c2 region it doesnt regiester any possible commands or folders i was able to install the device.config file on the etc directory successfully however the command C2 or any in this region do not exist basicly i just says not found ivbe tried going into the etc folder and run the command didnt work on the very first starting poage when you ssh into it also dindt work what am i doing wrong?I would be thankfull for any possible help.


Link to comment
Share on other sites

  • Solution

Note that C2 isn't a command in itself. What Darren is doing in the video is pressing tab (twice probably) to make the system "reveal" what known commands that starts with "C2". In any case, the available C2 commands should be located in /usr/sbin and those are the same that is shown in the video at about 8:20. If the commands aren't there, you should probably check what firmware version the Turtle is running. I can't see any reason why the Turtle should be on anything else than a version that supports C2 (which should have been introduced from version 5), but check it anyway to be sure.

The firmware version should be available in the top left corner of the Turtle text based UI/menu system, or by checking the file


  • Thanks 1
Link to comment
Share on other sites

Okay soo ive just found out that im indeed running firmware 3 while its already sixs but now i have another problem if i go on checking for updates and click on enter the only thing i see is ; Checking for updates..  And that for 5 minutes straight i think something is wrong here ? Any Idea and by the way it seems that i have an internet connection so i dont think its that is there a way to check that?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...