Jump to content

VII Setup - Downloading latest firmware - fork/exec /usr/bin/splitweb: cannot allocate memory

Recommended Posts

Hey there!

When I attempt upload the latest firmware which I downloaded from https://downloads.hak5.org/pineapple/mk7 vers. 2. 1. 3 (the latest stable) I get the error message fork/exec /usr/bin/splitweb: cannot allocate memory 

Same error when I tried earlier versions and the very first version.

alternatively, when I try and let the web UI "download the latest Firmware" it simply gives the generic error: exit status 1




Anybody overcome this particular problem?

I'd appreciate your help otherwise that's $100 down the drain, as they say.



Link to comment
Share on other sites

Check this thread



Some users have also tried the following:

Download the latest upgrade file from the Hak5 downloads web site and verify its SHA256 checksum, then:

1) scp the upgrade to your pineapples "/tmp" directory
2) ssh into the pineapple
3) cd /tmp && splitweb /tmp/upgrade-1.0.1.bin (or whatever firmware filename that has been downloaded)
4) sysupgrade -n /tmp/upgrade.bin


No guarantee that it will help and you're doing things like the instruction above at your own risk.

If you don't have the knowledge needed to do the operations, contact official support instead.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...