Jump to content

Issue with Setup on Mark VII


Recommended Posts

Hello, I recently purchased a Mark VII from someone who changed their mind about it and after quite a bit of rebooting, recovering and even trying older firmware I keep getting an error (phy2 MISSING) at the end of the setup process... at least when using the GUI. When I use a USB to configure I had no errors but it was almost as if none of the passwords too (management wifi or root) because they simply did not work however the pineapple did go straight to the login screen which was a sign of hope. See HTML report below: 


                                       .cxxdl'    xMMO    'cdxxl'                   
                                         ...:KMMMWMMMMWMMMXc...           .         
                            ,        .l0NMMMNXMMMMMMMMMMMMXNMMMWKl'      xWd        
                          ,0Wd         .':xNMMMMMMMMMMMMMMMMNkc'.        ;KM0'      
                         lWMo            .;dNMMMMMMMMMMMMMMWx:.      .l.   dMWc     
                        :WWo   oNd   .;xKWMMMMMMMMMMMMMMMMMMMMWXx:.  dWX:   dMW;    
                       ,NWo   oMW:   .. ..,lOXWMMMMMMMMMMWN0o;.. ..   cWMl   dMN'   
                      .XMx   oWN;   lc     .loooolcooclooool.    cXl   oMWc   kMK.  
                      oMW'  ,WMl   cMW:   lWMW0d:;cdd:;:o0WMWl   lMW:   OMW'  ,WMl  
                      0M0   xMX.  .XMd   .lo:.,dXMMMMMMXd,.:ol.   kMK.  'NMd   KMO  
                      NMd   KMk   lMN.  .;:xOxollccddcclloxOx:;.  'WM:   OM0   xMX  
                      WMo  .XMx   dMK   oNMMMMWOc;;ol;;cOWMMMMNo  .XMl   kMK   dMN  
                      NMx   0MO   :Kd. .lllcl;.:0WMMMMW0:.;lclll. .xK;   0MO   kMX  
  __          ___ ______ _   _____ _  .:W0;,oxl:::oOOo:::lxo,;0W: _     .ONo   KMk  
  \ \        / (_|  ____(_) |  __ (_)  ;cKMMMMWk:.;,.;kWMMMMKc;. | |          .OX:  
   \ \  /\  / / _| |__   _  | |__) _ _ __   ___  __ _ _ __  _ __ | | ___            
    \ \/  \/ / | |  __| | | |  ___| | '_ \ / _ \/ _` | '_ \| '_ \| |/ _ \           
     \  /\  /  | | |    | | | |   | | | | |  __| (_| | |_) | |_) | |  __/           
      \/  \/   |_|_|    |_| |_|   |_|_| |_|\___|\__,_| .__/| .__/|_|\___|           
 ----------------------------------------------------| |-- | |----------------------
                                                     |_|   |_|                      


Filesystem                Size      Used Available Use% Mounted on
/dev/root                21.8M     21.8M         0 100% /rom
tmpfs                   123.7M     92.0K    123.6M   0% /tmp
/dev/mmcblk0              1.8G      8.2M      1.7G   0% /overlay
overlayfs:/overlay        1.8G      8.2M      1.7G   0% /
tmpfs                   512.0K         0    512.0K   0% /dev

phy0    ../../devices/platform/10300000.wmac/ieee80211/phy0
phy1    ../../devices/platform/101c0000.ehci/usb1/1-1/1-1.1/1-1.1:1.0/ieee80211/phy1
phy2    MISSING

Bus 002 Device 001: ID 1d6b:0001 Linux 5.4.154 ohci_hcd Generic Platform OHCI controller
Bus 001 Device 003: ID 148f:7601 MediaTek 802.11 n WLAN
Bus 001 Device 002: ID 1a40:0101  USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.154 ehci_hcd EHCI Host Controller

Link to comment
Share on other sites

I guess you got some help on Discord. If both 7601 radios where gone, I'd say it would be the USB hub on the Pineapple that was toast. But when just one of them is gone, I'd guess it's that specific radio. Difficult to say why, maybe the previous owner fried it running it without antenna for some reason. The only power related thing to try is to make sure you use a power source that provides at least 2A (it should run on less than that, but just to follow what the docs say).

Link to comment
Share on other sites

Yeah I started on the discord channel and I did put in a ticket as suggested so I am going to see where it goes from there, I am still talking to the person I got it from so I put in his order number and such. 

I do find it strange that the setup completes seemingly okay when I do the USB setup because I can get to the login page however it doesn't accept the password from the config file (I even tried a completely unmodified version from the docs). But this is what gave me hope that it might be okay. As for the power, I used three different sources as a test and no change sadly. 

I did try to move the antennas around just to see it maybe it was the screw on portion causing the issue and no change but there was a time when I used all stub antennas that it worked but consistently looped the setup on boot each time (but did not give the error at the end of the setup ~ weird).  

Link to comment
Share on other sites

phy2 should be radio2 which in turn is wlan2 that should be used to connect the Pineapple as a client to an existing wireless network (for internet access, etc.), so if that is failing then the other features should work (such as the management interface, the open AP).

One thing that you could try that has worked for some users stuck in the config/setup loop is to connect using serial and check if you can see the following file in the file system:


If so, delete it and reboot. It's an "old trick" that was valid on earlier fw versions of the Mark VII, so not sure it applies in this specific case. Could be worth trying. Remember though that opening the Pineapple (to get access to the serial header) will void warranty, but I guess the warranty is gone with the wind anyway when it comes to this specific device.

Link to comment
Share on other sites

I did reach out to POTENTIALLY get a warranty something being that I did have the order number but I do not have high hopes so I will open it if that ends up being a dead end. I have confidence in my board soldering skills if I end up finding something broken inside prior to trying this specific thing. 

Thank you for the suggestion and I will be sure to close the loop on this topic when I find some resolve. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...