Jump to content

Bricking TETRA MK5.8 because of upgrading with NANO firmware


Recommended Posts

Hi, I wanted to upgrade my Wifi pineapple MK5.8 and I used a wrong NANO firmware. At first, I use recovery method form this link but I download the latest NANO firmware upgrade and insert that. After I upgrade a while, I recognized I used the wrong NANO firmware, which has to be TETRA firmware and I tried to access but it said the index could not be found, that means I cannot do anything now.

The UART and ETH can be connected normally. I can access uboot with Putty via UART and I can change the ETH ip to upload via tftp, how can I recovery the bricked wifi pineapple TETRA MK5.8 via UART? Big thanks in advanced!


Link to comment
Share on other sites

7 hours ago, JHT said:

I tried to access

So, when saying that, you tried to access the recovery web UI by following the firmware recovery procedure? Just want to be sure you have actually tried that. I.e. holding the reset button and apply power and hold the button for 10 seconds followed by accessing the Tetra using the Micro USB ETH port (as described in the link in your post).

Link to comment
Share on other sites

Yeah I tried the firmware recovery procedure from that link to first upgrade the firmware, but then I realized I chose NANO firmware instead of TETRA, I saw the yellow LED just stay solid so I removed all the power source. After that, I tried that procedure again but it said the index file could not be found and so that I cannot upgrade firmware with that way.

I then tried to do recovery via UART and found this youtube link so I tried to do that but no succeeded and seems like something broke the UART connection too, is it because of command `erase`? I tried to find the document for u-boot command but those command explanation made me confuse.

In case if the command `erase` the NAND chip, how can I recover that, by inserting u-boot image via a special device to NAND chip or send it back to the factory and how to do that?

Thanks in advanced!

Link to comment
Share on other sites

Well, there's no valid factory to send it back to. The Tetra has been end of life for years now and has also reached end of support status. Even if it was supported and still sold, it wouldn't be the correct way to send it to the factory anyway.

No idea if that YouTube video is valid for the Tetra. The only OpenWrt Hak5 device that I've seen being "reset" using serial is the Signal Owl. Don't know at all if that procedure is applicable to the Tetra.



  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...