Jump to content

Mark VII firmware recovery - upload via webpage times out


Recommended Posts


Recently my Mark VII (which was working) decided that something was wrong with the firmware and the page displayed a notice saying to do a full reset.

After 3-4 attempts I'm still hitting the same issue.  I go to the Hak5 download page, get the recovery firmware from the bottom of the page and try loading it.

All works up until it starts loading and then the connection times out after a while.

Not sure what to try next.  I've used the mk7_recovery_1.0.1.bin and copied it to upgrade-1.0.1.bin just to try it.  Both do the same thing.

Any suggestions?   Connected via USB-C to a Kali VM on a Mac.  I can ping the device and get to the web interface on the Kali VM.




Link to comment
Share on other sites

Well, I managed to get the recovery firmware on but when it goes through the setup and downloads the latest I keep getting the following.  Any suggestions?

It says it is downloading the latest directly from Hak5.



A flash error was detected on your device.

It appears that your device has been flashed improperly, and will not function correctly.

Please restore your device using the recovery process documented at

Remember you MUST flash the RECOVERY/STAGER FIRMWARE first before flashing the full firmware.

Link to comment
Share on other sites

  • 2 weeks later...

Tried several different USB power HUBS, all 3.0 and still have the same issue.   Checked the hubs and they are delivering good voltage and amperage.   Did mange to almost get it through the setup but it reverted back to the flash error screen.

Does anyone know of a quick way to test the internal flash without ripping it apart?  I'm starting to think it's a hardware error.

Link to comment
Share on other sites

One thing I should mention.  When using Kali in a Fusion VM, Firefox does not work well.  Install Chrome and at least it will make it to the "Update in progress" page....

Tried updating via wifi and via local upload, it uploads via both, tries to write the flash and looks successful but then comes up with the flash error on the device again....

Link to comment
Share on other sites

Managed to make some progress. 

Decided to try an older firmware after the recovery and used : upgrade-1.1.1-stable.2021083009481

Success so far.  Was able to configure it and now after a reboot it's still working.

I'm going to run it overnight to test and then upgrade it one firmware level at a time to see if an update was the issue.


Link to comment
Share on other sites

So far no issues with overnight usage performing recons, gathering handshakes on my own network and a couple of reboots.

Next will be to upgrade to the latest and see if that causes the issue again.

I wonder if there is a script or something that can run a test on the flash....    Will look into that if all goes well after upgrading.

Link to comment
Share on other sites

It's confirmed.     I can load the 1.1.1 firmware and no issues.   When I load any of the 2.x firmware it comes up with the flash error.  I've tried it twice.

For me here is what I did to get back to the 1.1.1 firmware:


  • Load the mk7_recovery_1.0.1.bin to the unit
  • Load the upgrade 1.1.1-stable to the unit
  • Use as normal without upgrading any firmware.

Does anyone know how to test the flash on the unit to see if it's some sort of dead cell or something?

Link to comment
Share on other sites

Tried but no answer via chat on Friday. Not sure if they were closed for veterans day but looking at the dmesg logs during the weekend it might be the flash as I saw the following:


[103676.228349] mmcblk0: error -145 transferring data, sector 1032, nr 1016, cmd response 0x900, card status 0xb00

[103676.248512] mmcblk0: retrying using single block read

No real way to test the flash unfortunately as smartctl and other utilities can't access the drive.  I might try forcing a fsck on reboot but won't know if that works as there's no console.

Not sure if this is the actual issue but another reason why I prefer replaceable storage.   I may try adding my own USB storage with the overlay on it to see if I can bypass the upgrade issues.

Link to comment
Share on other sites

  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...