Jump to content

Unable to Connect to Wifi - Key Croc


Recommended Posts

So I'm having an issue getting Key Croc to connect to wifi. I’ve gone through this same config.txt connection procedure with the Screen Crab and didn't have any issues, but I’m hoping that there’s still something I can change to get finally get the Key Croc connected.


I’ve tried with multiple APs, I’ve simplified the SSIDs and passwords to not need to break the spaces and special characters with \ , I’ve tried connecting to APs with no password (with and without adding key_mgmt=NONE to the wpa_supplicant file), I’ve connected to the device via serial connection and checked the wpa_supplicant.conf to verify that everything is kosher on that side, I’ve edited clean versions of the config.txt in Notepad++ on windows and with nano on my linux machines just to make sure there wasn’t any weird new-line stuff going on, I’ve updated the firmware (though interestingly enough the firmware that the device originally arrived with was reportedly 1.3.513 as opposed to the supposedly most recent 1.3.510), I’ve tried factory resetting the device (which brings it back to 1.3.510), I’ve let the device rebuild the config.txt file multiple times, I kinda’ don’t know what else to try at this point.


Do you guys have any ideas as to what to try next? The device does light up with that blue-ish cyan light when the config.txt file has wifi settings enabled so it seems to be trying to connect, it just never succeeds in getting a connection.


It does collect keyboard input without issue though, so that's pretty cool. 


But yeah, any additional wifi connection tips would be appreciated at this point.  

Link to comment
Share on other sites

If you serial into the Croc when it's in arming mode and run ps ax to identify the PIDs for the processes listed as

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf -B
(might be cut off and shorter than above due to width limits of the current terminal)


dhclient wlan0

kill those processes with: kill -9 <PID>

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf -B

then, run
dhclient wlan0

Do you get any error messages?

Link to comment
Share on other sites

Hey there dark_pyrro,


I appreciate the response, but I don't appear to get any error messages after killing and then re-starting wpa_supplicant and dhclient. It might be worth noting that dhclient wlan0 takes 30-45 seconds to complete, but it doesn't return any error messages, whereas running wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf -B informs that it has successfully initialized. 


I've tried this against two APs so far, one with no password and one with a password. Neither appear to be able to give the device an ip address. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...