Jump to content

Key croc will not change language to be


David1984
 Share

Go to solution Solved by dark_pyrro,

Recommended Posts

Hi,

I tried to change the language in the config.txt file to "be" 

However the key croc is not changing to Azerty layout so payloads do not execute as it should.

Is there another way to change the keyboard language?

It also doesnt connect to my c2 cloud. Could this keyboard issue be the reason?

 

Thank you for your help

Link to comment
Share on other sites

  • Solution

It was a while ago since I used the Croc, but I seem to remember that I had to force the Croc to use something else than US. Setting the language in config.txt or in the payload didn't matter. I ended up changing/hardcoding the language into the QUACK script file. Not sure if it's relevant to your scenario, but I got it to work that way.

Change line 263 in /usr/local/croc/bin/QUACK from
    language = os.getenv("DUCKY_LANG", default="us").lower()
to
    language = os.getenv("DUCKY_LANG", default="be").lower()

For some reason, it seems as if the Croc isn't reading the DUCKY_LANG variable. I can't at least find any code for that in croc_framework in the parse_config function (where it feels like it should be located).

Try it and see if you get things working. You may also need to inspect the be language file as well since it's not 100% sure it's complete.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...