Jump to content

Papers Module Bug on Nano (fw v2.7)


Reunion
 Share

Recommended Posts

Kind of a continuation of another post that I revived a dead post for, sorry about that. Think I KINDA got it solved.

This thing [Nano] has been weird since running Papers. Could not enter fw reset; after many, MANY attempts I was pretty sure I bricked the thing. Then, suddenly, I was able to get into it - not even in firmware recovery, but reset... but in current fw? It makes me feel crazy, but, for some reason - yeah. Can't reset firmware. Had no problems with that before. Man that 172 made me freak out. Anyway.

It seems that, at least on the nano, the dependency set up for that module is totally whacked on this fw. On 2.5.7, I think? Something like that? Sure, it wouldn't run - but this time it seems to have totally bugged the thing. Doesn't register as dependencies installed, and when you go to install them - boom. Crash on refresh. Even if you wait 30m.

Also, after the first crash, it's behaviour has become... sporadic. In short, sometimes it does not auto lease an ip from dhcp, and sometimes it does. In those instances where it does not, assigning an ip in either 192.168.1.2 or 172.16.42.42 /24 ranges yields ip and mask of /24 for both in reality. And yeah, I know this can be a problem with the boot time in some instances as it tries to lease - but I waited 15 minutes in some cases before assignment, so I doubt it's that.  Not that I didn't waste plenty of time messing up not realizing that at first.

I'm not gonna test around with it anymore; will uninstall and trudge through without it. Just wanted to put this bug report somewhere a little more public than where I had it; not sure if anyone else has had success with this mod but my nano's factory, minus a few modules on the SD that I'm fairly sure would not conflict and are even used in conjunction for a specific attack I'm trying to try out. Plus they're not yet configured. Oh, and papers is installed on SD, just to give the full scoop.

Luckily this thing is just as hard to brick as Darren says; always loved these devices, had the original even - that one had a few issues but, this one, man, it's been largely perfect. Never had anything like this - a few newb moments maybe but nothing to post about. If anyone has any insight on this strangeness, would love to hear about it - thinking of buying another if these bugs persist. But for tonight I'm just glad to have it functional again. Also below is the original post which I'll delete before bed, if that's an option here.

 

Quote

I encountered a strange bug with the nano.

So, had a functional nano - still do from what I can tell. Did a factory rest, no big deal - updated to latest firmware after. Reason why I did all this: Problem with Papers and dependencies (no other modules, all installed fine on 2.5). Thought I'd try to trouble shoot, yknow - revert, test, update, test.

Everything was going smoothly, then I went to install those dependencies again. After that, well, now my device just won't allow access - and is acting all kinds of finnicky. Won't function in certain usb ports, not broadcasting ap's; and worth noting, when it does broadcast the mgmt point, I still can't reach the portal. Had no issues with it before; maaaaybe a little touchy with the captive portal mod.

Gonna try another rest if I can't get this to work, re-update - one thing I will note is that I wasn't connected to the net for the actual dependency installation at the time i pushed the button, so, maybe some issue there - unless something else comes to mind I don't know about?

If not resolved or similar, can make a new post - but while combing the forums this one seemed relevant so, I thought it was appropriate here. Sorry on the revival.

And yes I've tried setting it to the 42.42/24.


Okay guess you can't delete posts, but it's consolidated at least.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...