Jump to content

Flashing Firmware - Connection Issue


ehosinski
 Share

Go to solution Solved by ehosinski,

Recommended Posts

Hey everyone,

I have a similar issue to another post I saw where by I was being told that my brand new Pineapple could not connect to any other wifi. I then downloaded the ;latest firmware 1.1.1 stable and have been trying to install it via usb. At first it gave me an error about memory allocation but then quickly flashed over to "Flashing FIrmware." 

The problem is, it has been flashing the firmware for nearly 45 minutes. Is this normal? I am afraid to stop the flash and brick the unit at this point. Any idea what to do? Again this is a brand new unit.

Link to comment
Share on other sites

Are you using the recovery firmware image or the "ordinary" firmware image (seems like the latter since you mention 1.1.1). Try using the recovery firmware image instead. It will automatically download and install the latest firmware later on on the setup process. The reason to why it seems as if it's flashing "forever" is just because it disconnects during the flashing process. Just reconnect to the Pineapple.

Link to comment
Share on other sites

  • Solution
1 minute ago, dark_pyrro said:

Are you using the recovery firmware image or the "ordinary" firmware image (seems like the latter since you mention 1.1.1). Try using the recovery firmware image instead. It will automatically download and install the latest firmware later on on the setup process. The reason to why it seems as if it's flashing "forever" is just because it disconnects during the flashing process. Just reconnect to the Pineapple.

I have tried 1.1.1-static, 1.0.0 and 1.0.1 and none of them worked. This is my first pineapple setup so I can't argue there isn't some user error involved but I disconnected and reconnected the pineapple, waited for it to boot, configured the network settings and then went back to the link and did the quick single press (it is plugged in via usb-c). That seems to have got it updating without complaining about connecting to a network. I am hoping this works but if not, where can I find the recovery firmware image? When I try to access the documents I get a 404 error. It looks  like they are down.

https://docs.hak5.org/hak5-docs/hc/en-us/categories/360004116253-WiFi-Pineapple-Mark-VII

Link to comment
Share on other sites

1 minute ago, dark_pyrro said:

Recovery image is available here
https://downloads.hak5.org/pineapple/mk7

The docs site has been "rearranged". Old URLs doesn't work anymore. Start from docs.hak5.org and move in further from there.

https://docs.hak5.org/hak5-docs/

https://docs.hak5.org/wifi-pineapple/

Thanks so much! I think I resolved my own issue after the last attempt that I posted but I appreciate the help! and the docs!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...