Jump to content

TXPower with the "Long Range Wifi Booster"


hexdigest
 Share

Go to solution Solved by dark_pyrro,

Recommended Posts

Hey Guys,

i have a problem with my Pineapple. In my location i couldn't really use the potential for the device so i bought the Wifi Booster. I found articles about changing the TXPower to the actual max instead of the pre-configured 20dbm. I tried many ways with iwconfig and some scripts but the result was no change at anytime.

If you have any ideas of how to fix this i would love to hear them because i dont find any fix.

 

Have a nice day guys 

Link to comment
Share on other sites

Just now, dark_pyrro said:

Pasting in the same comment as I had on Discord

not at all sure if it applies to the Mark VII but radios/adapters (whatever) are restricted at least on driver level when it comes to TX settings, most often based on regulatory compliance and on what country is set, ETSI has a 20 dBm limit

Thanks m8 i will try to wait until someone maybe now some workaround or something.

Link to comment
Share on other sites

22 hours ago, dark_pyrro said:

I guess that if you (Hak5 that is) want to sell the Pineapple you have to commit to the rules and regulations that is out there, either it be FCC or ETSI or anything else

Is Openwrt, the subsystem the pineapple is built on, confined to the regulations of your specific country? Or can't you not CHANGE the country code in configuration?

 

Asking for a friend.. Above. 🙂

 

I legit don't know anything, so definitely don't listen to me. Seriously.. But google 'iw reg set' maybe it can help.. Maybe not.

 

Edited by cluckomatic
Link to comment
Share on other sites

35 minutes ago, cluckomatic said:

Is Openwrt, the subsystem the pineapple is built on, confined to the regulations of your specific country? Or can't you not CHANGE the country code in configuration?

 

Asking for a friend.. Above. 🙂

 

I legit don't know anything, so definitely don't listen to me. Seriously.. But google 'iw reg set' maybe it can help.. Maybe not.

 

I tried changing the State from DE to BO and GY but both didn't work

Link to comment
Share on other sites

  • Solution

Using such country settings has been a "workaround" before to increase TX power/dBm (not related specifically to the Pineapple). This has changed over time though and the limit is often set in firmware. Changing settings/country in the software/OS won't affect that since it's on a higher level of "abstraction". Firmware rules over software/OS. It's all about compliance. One of the larger vendors of network equipment quite recently was sanctioned to pay a significant amount of dollars in fines as they violated set rules. Write your own firmware (not that likely at all to happen) or perhaps try to find some older adapter with old firmware that lacks these restrictions. Haven't tried since I don't see the real need to just have TX increased. In most cases you have to "hear" as well, not just shout.

  • Upvote 1
Link to comment
Share on other sites

I've definitely had luck, not just with the pineapple, with different antennas. I've got a nice yagi for 2.4ghz that I made that out performs anything I've bought (directionally).. Not a definitive solution, or may not even be applicable in your jive... But just thinking out loud. Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...