Jump to content

Keyboard dead keys


Athylus
 Share

Recommended Posts

Whatsup!

I just got my rubber ducky and am playing with it joyfully. Now I am from Europe and use a dead keys keyboard layout.

For those that don't know what it is, it means that certain characters (incidentally critical to my script) such as a double quote (or single quote) don't get typed immediately when you press the key. Instead, the next input will determine what happens. So if I type " + a I will get ä. Quite a pain in the ass when you try to define a base64 encoded string variable in a powershell oneliner.

Now I tried going the " + space + [base64 string] +  " + space. But if the keyboard settings does not utilize dead keys, my string will not be correct.

A great thing would be if I could make this script work for both dead keys keyboard as well as non-dead-keys layout. Does anyone have any tips for this?

 

Thanks and regards

Link to comment
Share on other sites

If you are using a target that uses a US keyboard layout, then that's not a source for your problems. There are more than 3 by the way. Using the JS encoder along with the language files for the Bash Bunny gives you several options. But if you want to get umlaut chars, I would suggest using some language layout that has those chars natively instead.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...