Jump to content

How to get bettercap to recognize my wifi adapter?


Joeneedshelp1
 Share

Recommended Posts

  So I am having the problem of having bettercap recognize my wireless adapter in Parrot and in Kali.  Does anyone else have this issue?  I am using a wifi adapter that supports monitor mode and packet injection.  I have no problem putting it into monitor mode not in bettercap, however in bettercap it will not work.  I get the following error:

wlan1  » wifi.recon on
[17:41:07] [sys.log] [inf] wifi using interface wlan1 (1e:ce:b8:d0:5f:10)
[17:41:07] [sys.log] [war] wifi could not set interface wlan1 txpower to 30, 'Set Tx Power' requests not supported
[17:41:07] [sys.log] [war] wifi error while activating handle: error while setting interface wlan1 in monitor mode: Cannot set rfmon for this handle, interface might already be monitoring. retrying!
[17:41:07] [sys.log] [inf] wifi started (min rssi: -200 dBm)
 wlan1  » [17:41:07] [sys.log] [inf] wifi channel hopper started.
 wlan1  » [17:41:10] [sys.log] [war] wifi error while hopping to channel 12: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:41:11] [sys.log] [war] wifi error while hopping to channel 13: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:41:11] [sys.log] [war] wifi error while hopping to channel 14: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:41:15] [sys.log] [war] wifi error while hopping to channel 12: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:41:15] [sys.log]

wlan1  » wifi.show

wlan1 (ch. 1) / ↑ 0 B / ↓ 0 B / 0 pkts

 wlan1  » [17:42:00] [sys.log] [war] wifi error while hopping to channel 12: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:42:00] [sys.log] [war] wifi error while hopping to channel 13: iw: out=kernel reports: Channel is disabled
command failed: Invalid argument (-22) err=exit status 234
 wlan1  » [17:42:00] [sys.log] [war] wifi error while hopping to

 

   I don't understand what is going on, tried wifi.show command and thats all it responded with.  Anyone have any suggestions?

Link to comment
Share on other sites

What wireless adapter are you using? Are you sure you have "killed" any other process(es) that might be active binding that adapter in monitor mode? Then you need to put it in monitor mode so that bettercap can use it (something like wlan1mon using airmon-ng).

You could also check the libpcap version used. There has been some rather recent reports on possible bugs that might result in issues like the ones you face.

Edited by dark_pyrro
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...