Jump to content

Rubber Ducky not recognized in Android 6.0


Mur
 Share

Recommended Posts

Hi, I'm opening this topic because I need some help trying to execute my Rubber Ducky on an Android phone. The target is a LG X Power (LG-K220) running on Android 6.0 (Mashmallow), no root and ADB debugging disabled. It's currently locked with a pattern and an alternative PIN that can be input after 5 incorrect attempts over the pattern lock. The reason I got my ducky in the first place was to bruteforce the PIN, as it has no maximum attempts before it blocks nor cooldown.
 
I load a simple test payload into the ducky to try its behavior on the phone, but it won't load when I try to connect it to it via the USB adapter. I've tried to connect the ducky into a PC just to see if the device was broken but my PC detects it and works fine (green led is shown too). Whenever I plug it into the phone, no led is shown. I've tried a couple different USB adapters but none of them worked. I was afraid it could be some hardware issue, so I connected the phone to my PC but it was recognized as an external device. Also, the charger works fine.
 
I also tried to add a DELAY 10000 into my payload just to see if it was some kind of problem recognizing the device, but it didn't work

Please, could you help me with this issue?

Thank you in advance.

Link to comment
Share on other sites

Could it be a problem of the phone? I don't have the knowledge of how the ducky works at a hardware/firmware level. Is there maybe any kind of update for either the phone or the Ducky I could install? Maybe some kind of insufficient voltage amount for the phone to detect the ducky? Any idea is appreciated.

Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...