Jump to content

[RELEASE] WiFi Pineapple Mark VII Firmware 1.1.x


Foxtrot
 Share

Recommended Posts

2 minutes ago, dark_pyrro said:

I'm so happy I was finally classified as a fanboi. It has always been my goal in life and now I won the Oscar! I'm all open to hear about bad things, I'm a user too, but when things are ventilated in ways that is too vague, I need to ask. Being specific is a good thing and when it becomes too blurry, it's just some kind of general opinion based on "something". And... "we"?! Is there some kind of club that collectively is passing judgement on Hak5 forum users?

grow up. you know what i meant

Link to comment
Share on other sites

On 1/25/2022 at 12:57 PM, princesstoadstool said:

Adding features, upgrading components etc.  plenty of reasons to update it.   Noone wants to buy an easily updatable system to sit there and not have any additional goodies added to them over their lifecycle.   Its shit practice to not add stuff until the next hardware iteration is released. 

You mean like the addition of the Evil Twin feature? Perhaps the addition of the Package manager and all of the pre compiled Packages? Maybe the addition of the wireless landscape view, C2 support or one of the many other features that updates have added since the devices release? Just'sayin'

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Just wanted to throw my two cents in here. I got my device yesterday and it's running 1.1.1. To say it's buggy is an understatement. Two-ish years from release I was expecting a polished product but this is not. I've spent the better part of 4 hours trying to get the basic set up done and it's still not working.

- Client mode doesn't work, I can't connect to any Wifi AP. The connect endlessly spins (Console is giving not authorised errors to various API end points) and when it does connect, it doesn't get an IP address. Refreshing the page seems to kill the connection and it asks to connect again. Tried in multiple browsers.

- Packet capture doesn't work.

- Web UI regularly locks up.

- If you connect the 5GHZ adapter at the wrong time, it locks the UI (Especially if there is another notification showing at the same time)

- 5GHz adapter isn't seamless, it's not picked up half the time in PineAP so you need to tinker with the Recon settings to get it to show up. 

- You cannot reflash this device with MacOS. This is a big issue for me as I need to spin up a VM, or find a Windows/Linux rig to fix it. Support for recovery from a USB key would be helpful.

To say I'm bitterly disappointed in this device is putting it mildly. It's frankly garbage and I feel utterly robbed, and I say that as an owner of a Nano, Mk5 and various other Hak5 pieces. If this was an open source project, I'd be forgiving but this is a premium, paid product and it's simple not good enough. At best it's incompetence, at worst it's wilful fraud as a cursory search of the forum here suggests I am certainly not alone in my issues and issues are not being actively addressed.

Guess I'm the definition of getting fooled more than twice.

Link to comment
Share on other sites

This doesn't look normal for sure. I have been on the 2.0.0 beta/RC for a while now, but 1.1.1 wasn't giving me such issues at all. I've noticed some users that seems to have experienced issues recently with their newly delivered Pineapples. No real evidence that there might be some big flaw in production lately, but it might be. I have no full insight in the architecture and design, but USB perhaps seems to be a part of the equation. And when saying USB, I mean hub related since this ties a lot of things together that you seem to have problems with. Did you have issues when setting the Pineapple up as well? As a first step I would probably do a firmware recovery, but I realize your situation being a Mac user. Since it's being tagged as an "unsupported" client platform when it comes to connecting to the Pineapple using the USB-C/Ethernet interface, I wouldn't add that layer of complexity when troubleshooting the issue. Not running it using a VM either. If it is possible to get hold of a Windows or Linux box, that would be the best way for sure. In any case, I would most likely submit a support ticket to Hak5 to get an official view and response on this.

Link to comment
Share on other sites

Thanks dark_pyrro, I spun up a RP to reflash the Mk7 with 1.1.1 A couple of notes after I did:

- I set up without the 5Ghz adapter connected this time.

- I set up with radios disabled over the USB-C connection to the RP, and uploaded the bin as opposed to OTA.

- 1.1.1 seemed more stable but the UI still felt laggy to me. Maybe I'm expecting too much but it felt slow and clunky.

- Client mode worked correctly but there is a bug if you enter the wrong network password, it says connected and spins endlessly. When you do enter the right password, it connects but doesn't refresh, you need to refresh the entire UI to see if you got an IP address.

- Internet connection was a little buggy once connected, I could list modules but then a moment later I couldn't, even though client mode wasn't changed.

I then updated to the 2.X beta and it seems more stable, but overall I'm not impressed with the device, it just seems 'off' and I don't trust it to be reliable as it's given so much trouble to even get it going. If there is any way to test or verify the hardware, I'd be interested in learning more as I'm now convinced I have a duff board.

Edited by ironclaw
Link to comment
Share on other sites

  • Dragorn unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...