Jump to content

DHCP issue with Mark 7 on MBP?


Recommended Posts

Hi everyone, 


I just got my new Mark 7 and try to configure / setup it. 

According to the documentation (https://docs.hak5.org/hc/en-us/articles/360053346334-Setup-Basics) I installed the ASIX driver on my 16" MBP Big Sur. I also activated it manually via Applications folder. 

Plugging in the Pineapple now gives me a signal on the ethernet port. However DHCP keeps to fail constantly. 

When I use the WiFi in parallel, connecting from my iPad, DHCP and access to the WebUI works fine. 

Anyone any idea what this might be and how to fix it?


Link to comment
Share on other sites

20 hours ago, chrizree said:

Big Sur has driver issues, changes has been made compared to previous OS versions.

Mmh, damn. So apparently no update on the driver and stuck like this. Thanks for the input. Sad to see this known glitch being still present. 

Link to comment
Share on other sites

10 minutes ago, chrizree said:

Just skip the cable and use WiFi instead

seems so. This means I would also need another WiFi adapter to share my internet connection from my MBP with the MK7, right? 

Probably gonna use it via my Kali VM and hope it works there. 


Link to comment
Share on other sites

1 minute ago, chrizree said:

Why not connect your Mk7 directly to your home WiFi AP/router (or some similar alternative)? I avoid internet connection sharing anytime possible.

Various things (which might be due to outdated knowledge on my end):

Using client mode would interfere with PineAp operations. This means I would need another USB WiFi adapter. this would be blocking the port for an 802.11ac adapter. Maybe this could be solved with a USB hub, but this would add more dangling equipment. 


To begin, first note that while the WiFi Pineapple includes two radios (wlan0 and wlan1), they are both required for PineAP operation. If the second radio (wlan1) is used for Client Mode, PineAP functions may not be used. For this reason the auditor is advised to use an external USB WiFi adapter with a compatible chipset.



Second thing is that I use it also for example to monitor the internet uplink traffic, mainly via BURP, as a demo case for students etc. This would be more tricky if it would involve another AP. Again, this could probably be solved via proxy settings on the client, so traffic flows from client to WP to AP to proxy VM, but it involves more moving parts to configure plus it allows only monitoring of proxy aware protocols. 

Link to comment
Share on other sites

There is no "interference" on the Mk7 between using client mode and PineAP. That quote is valid for older generations. Just use the "onboard" wlan2 to connect using client mode. Any additional 5 GHz USB NIC will be wlan3 (if using the beta firmware at least).

Link to comment
Share on other sites

@chrizreebrief question. I connected the MK VII with a linux box, yet DHCP doesnt work out of the box. Just when I manually added it to /etc/network/interfaces I got the corresponding IP address. 

However it messes up my routes and I lose internet access (because the MK7.lan announces an automatic route metric 0). 

Do you know whether this is the expected behaviour?

I need a workaround anyway. 

Accessing my WiFi to get the OTA download for the MK VII fails because it only accepts 32 chars passwords. 



Screenshot 2021-08-03 at 17.10.46.png

Link to comment
Share on other sites

DHCP? In what perspective? How are you connecting to the Mk7 and how is it getting internet access? ICS or using client mode on the Mk7? If using client mode it shouldn't mess any routes up for connected clients. If using ICS, then the wp7.sh script needs to be used if the ICS is being set up using a Linux based machine. Or, it's not needed, but it simplifies the setup.



As I remember it from some recent Discord discussions, the limitation when it comes to the possible number of PSK characters should be adjusted in coming firmware.

Link to comment
Share on other sites

Currently I am connecting the MK7 via USB-C ethernet to a linux box. As it was working yesterday I am now struggling with DHCP. 

The device is recognized, via lsusb, ifconfig, ip link, etc., but it wont get a DHCP assignment from the MK7. 

This also doesnt work when I explicitly configure it via nmclient or via Debian Network Manager GUI. 

So I first have to figure out what is wrong on that end. 

Yesterday ICS was working via wp7.sh script. 

PS: Thanks for the hint on the PSK chars and the upcoming firmware.


Edit: Linux is really getting me crazy. I enabled NetworkManager to manage my NICs. 

First when I plug in the MK7 via USB-C, I see the "getting IP configuration" output for eth1. After a few seconds it changes to "unavailable". 

further investigating this. 

Screenshot 2021-08-04 at 17.32.44.png

Screenshot 2021-08-04 at 17.33.12.png

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...