Jump to content

Read-Only file system when trying to scp C2 config file to pineapple nano


Driftwood8891
 Share

Recommended Posts

Hey guys i just got my C2 server set up today and i am trying to add my nano.  Following the hak5 instructions to copy the config file to my pineapple and i get a

sudo scp device.config root@172.16.42.1:/etc/                           1 ⨯
root@172.16.42.1's password:
scp: /etc//device.config: Read-only file system

Any thoughts on why this is happening?  Wasn't for sure if you could copy the config file to the SD card i have in my nano possibly?

Thanks!

 

 

Link to comment
Share on other sites

If you ssh into the Nano, is it possible to create files in the filesystem from the terminal? Sometimes read-only situations might occur if there are errors in the filesystem (not unique to the Nano specifically, but Linux based systems in general). If it's possible to create files locally using an ssh session, you can try to do it the other way, i.e. "pull" the file from the PC to the Nano (from the Nano side).

Link to comment
Share on other sites

So was able to ssh into the nano and tried creating a file with the touch command but i still get the same "Read-only file System" output.  Actually when i ssh into the nano i get this "pineapple nano jffs2-partition seems full and overlayfs is mounted read-only".

It then suggests to remove the files from the /modules directory and then reboot.  I did this and the i still get the same error when trying to copy the config file to the nano.

I read somewhere to try a factory reset to clean the filesystem... Its really not that serious of a problem to me. I was just trying to connect the nano with my C2 server.  I think ill try copying the config file to the sd card before i do a reset.  Pretty sure the config has to be on the /etc directory of the nano though. 

Link to comment
Share on other sites

You have a point there, the Nano might be out of storage space. Just run df -h when ssh'd into the device to see available space. I seem to remember that I've experienced something similar now that you mention it. Not sure it was the Pineapple though. But, as you say, perhaps easier to reset it and start from scratch.

The config file should be in /etc

https://docs.hak5.org/hc/en-us/articles/360014295634-Adding-Devices-to-Cloud-C2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...