Jump to content

Questions about WiFi Pineapple USB Wifi adapter config


Recommended Posts

Hello,

I need some clarification to understand what I am doing.

After plugging my RT5390 WiFi adapter (sold by Hak5 with my WiFi Pineapple NANO, but not used until yet…), I can verify if the adapter is recognised by the Pineapple…

root@Pineapple:~# dmesg | tail -n 5	
[  865.323205] usb 1-1.3: new high-speed USB device number 5 using ehci-platform
[  865.613332] usb 1-1.3: reset high-speed USB device number 5 using ehci-platform
[  865.783339] ieee80211 phy2: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
[  865.869931] ieee80211 phy2: rt2x00_set_rf: Info - RF chipset 5370 detected
[  865.902917] ieee80211 phy2: Selected rate control algorithm 'minstrel_ht'
root@Pineapple:~# lsmod | grep rt2x00
cfg80211              232618 11 rtlwifi,rtl8187,rt2x00lib,mt76x02_usb,mt76x02_lib,mt76,ath9k_htc,ath9k,ath9k_common,ath,mac80211
mac80211              465192 14 rtl8192cu,rtl_usb,rtlwifi,rtl8187,rt2800lib,rt2x00usb,rt2x00lib,mt76x2u,mt76x02_usb,mt76x02_lib,mt76_usb,mt76,ath9k_htc,ath9k
rt2x00lib              36563  3 rt2800usb,rt2800lib,rt2x00usb
rt2x00usb               8473  1 rt2800usb
usbcore               134398 35 smsc95xx,sierra_net,rndis_host,qmi_wwan,cdc_ether,ax88179_178a,asix,usbnet,ums_usbat,ums_sddr55,ums_sddr09,ums_karma,ums_jumpshot,ums_isd200,ums_freecom,ums_datafab,ums_cypress,ums_alauda,cdc_wdm,cdc_acm,rtl8192cu,rtl_usb,rtl8187,rt2800usb,rt2x00usb,mt76x2u,mt76x02_usb,mt76_usb,ath9k_htc,usb_storage,uhci_hcd,ohci_platform,ohci_hcd,ehci_platform,ehci_hcd
root@Pineapple:~# 
root@Pineapple:~# lsusb
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc. Logilink CR0012
Bus 001 Device 003: ID 0cf3:9271 Qualcomm Atheros Communications AR9271 802.11n
Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@Pineapple:~# 

I think that everything is ok…
The WiFi adapter look like recognized and ready to use.
Nothing has changed in the the web admin interface of the WiFi Pineapple NANO, which is normal since the adapter is not yet configured in /etc/config/wireless (https://docs.hak5.org/hc/en-us/articles/360010471494-WiFi-Client-Mode).

I found a config mini how-to at the URL: http://h-wrt.com/en/mini-how-to/wifi_openwrt
I think that I need to append the following lines in the existing /etc/config/wireless file.

config wifi-device 'radio2'
	option type 	'mac80211'
	option channel	'auto'
	option hwmode	'11n'
	option path	'platform/ehci-platform/< must be completed > 
	option disabled	'0'

config wifi-iface
	option device	'radio2'
	option network	'wwan'
	option mode	'sta'
  • Do you agree with this first step?

  • How can I found the path to use for the radio device configuration ?

  • Will 'radio2' be automatically linked to 'wlan2'?

In the OpenWRT doc I read, the credentials to the access point connection (SSID & key) are stored in the /etc/config/wireless file:

config wifi-iface
	option device		'radio2'
	option network		'wwan'
	option mode		'sta'
	option ssid		'testwifi'
	option encryption	'psk2'
	option key		'1234567890'

 

  • Does that mean, that I can configure only one access point?
  • Can I use a wpa-supplicant configuration for one network at home, one at work and so on, like on a Linux laptop?

But I did not find a file like wpa_supplicant.conf in the WiFi Pineapple NANO system files…

 

Thank you in advance for your explanations.

Regards,

 

Éd.

Link to comment
Share on other sites

I'm not sure if I follow you here, are you trying to set up yet another AP (apart from the already existing ones)? The file you should use is the one you already have mentioned since there is no wpa_supplicant file (and that file shouldn't be used either for AP configuration even if it was a device that was running, for example, Debian). Per device it may be possible to configure multiple interfaces/wireless network.

https://openwrt.org/docs/guide-user/network/wifi/basic

Link to comment
Share on other sites

I want to mount the extra WiFi adapter as wlan2, in client mode, to use my WiFi Pineapple NANO alone, just plugged into a battery...

I will look at the URL you sent me. Thank you.

Link to comment
Share on other sites

If you want to use the extra adapter as a client to another network, you shouldn't need to do anything else than go into the Pineapple web GUI and select the "external" adapter and use it to connect the Nano to a WiFi network. It's how I use (or used) my Nano 90% of the time. There is no need to configure anything in the file system if the adapter is supported.

  • Like 1
Link to comment
Share on other sites

🤣
I am so used to doing my system configurations by hand with Vi!!!
🤣

 

For information, the GUI appends in the /etc/config/wireless file:

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ehci-platform/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio2'
        option ifname 'wlan2'
        option mode 'sta'
        option network 'wwan'
        option ssid 'myMobileWiFiSSID'
        option encryption 'psk2+ccmp'
        option key 'myMobileWiFiKey'

and the path "platform/ehci-platform/usb1/<etc>" is a subsystem (like "/dev") in "/sys/devices"…

I had almost reached the same point with the couple RTFM & Vi!

I will put a note on my computer screen:
"⚠️Visit the GUI before use SSH & Vi…" 😁

 

Regards.

Éd.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...