Jump to content

Problem getting into the management API


Recommended Posts

Hello there. I didn't want to have to ask about this here but after researching online and finding nothing I've decided to.

My problem is that every time I connect my Wifi Pineapple VII over usb to my Windows or Kali machine, and log into the Pineapple_XXXX network (or don't) and go to the portal requires that I "Begin Setup". Every time. It does not save the configuration.

The biggest problem is that for some reason at the first stage of setup "Verify your Device" neither of the options work for me. Clicking the button on the front of the device once or holding it for 4+ seconds, results in nothing. Even after waiting for multiple hours, the button on the 172... portal still reads "Awaiting verification"

Please help! It only worked once, the very first time used it and since then I am met with this problem.


Link to comment
Share on other sites

I'm a bit confused about your scenario since you mention that you connect via USB to the Mk7 as well as via doing a login to the WiFi/AP of the Mk7. I think it's a good thing to select one of them, not trying to use both at the same time, i.e. use USB-C ethernet only or WiFi only. If you use USB-C you should quickly press the hardware button on the side of the Mk7, if using WiFi the press it for 4 seconds. Remember to press it firmly (but not with too much force of course). Some seem to press it with not enough force which results in no action at all. You say it has worked before, so I guess it skips the step of downloading the latest firmware and heads directly over to begin setup (or?).

Link to comment
Share on other sites

Thank you. Sorry, I should have specified that it doesn't matter which way I choose, I can never get it passed the "awaiting verification" stage of the setup. The Pineapple does require power, and it receives such power from the USB-C port, so I always have it connected to my laptop, just for power. Then I connect via wifi.

Link to comment
Share on other sites

Just to be sure, is it possible for you to only use one interface at a time and either make sure you get network access using the USB-C cable only, or power the Mk7 using something else than the PC (some power source that produces at least 2A) and then connect using WiFi alone?

  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...