Jump to content

Cannot setup


robbo1979
 Share

Recommended Posts

Hi all.

Im having trouble setting up.

It won't complete the setup stages, keeps hanging and dropping wifi. I've followed all the tips online, I've done a factory image reset, then installed the latest firmware image tried many different usb power adapters, also using a 2.4amp power supply, so it's not a low power issue. Tried setting up without WiFi and a direct network connection but still issues. It wil not complete setup stages, it ask for magement ssid etc, and i input al of this but then hangs. Tried resetting many times

Link to comment
Share on other sites

Exactly what part of the setup are you having problems with and does the Mk7 "hang" during any specific setup steps? Since you mention management SSID you at least seem to get to the Networking Setup part, but do you get any further or is it where it all hangs?

General Setup
Networking Setup
Filters Setup
Look and Feel
Terms of Service & License Agreement
(Setup Complete)

Link to comment
Share on other sites

I install the firmware, then it load to the setup page, i enter all the info and most of the time it errors setup failed. i keep restarting and trying again and i did get it to accept. then once rebooted i can see the management ssid i created, but when i connect to that i cannot see the pineapple login screen

Link to comment
Share on other sites

3 hours ago, robbo1979 said:

must add ive tired the setup linked to wifi on my pc, and also on my mobile. same issue

Hi, 

Have you tried plugging this into your computer via USB and completing the setup that way without connecting via WiFi? 

Not sure if you've tried this or not so apologies if you have

Link to comment
Share on other sites

1 hour ago, chrizree said:

Activating (or de-activating) PineAP shouldn't affect the management SSID/AP

On mine it does, if i connect through wifi then putting PineAP in passive mode its absolutely fine, when i set it into active mode, it doesnt connect through wifi anymore. It doesn't really bother me though because i use a wired connection with it most of the time and never have an issue with it that way. 

To be fair though, since i've used the 5Ghz wifi adapter, it hadn't done it so its maybe something in one of my config files where its trying to use same radio when i switch it to active.

Link to comment
Share on other sites

  • 9 months later...

I go through the whole setup process as well, doing it via wifi. Everything seems fine, then it tells me to wait while it redirects, then up shows "Setup failed. Please try again." Then it places the blue button below it that shows Begin Setup on it. I have done this via phone and via PC using this wifi network. I am currently on the custom Wifi connection network that I defined and it works well, but always assumes that I need to setup. Anyone else have any idea what causes this? (again note: firmware updated and all other steps of the setup go fine prior to the fail message)

Link to comment
Share on other sites

Is it possible to access the Mark VII using ssh in the state your are now? It was a while since I did the setup now (and I usually don't have any issues with it) so I don't remember. I've heard/read about similar problems, but the message was "Config failed. Please try again" in that case. Not sure if that was correctly cited though. Anyway, the user opened the case of the Pineapple and connected to it using serial (hardware) and discovered that the file "setup_required" was present in /etc/pineapple. After removing that file and rebooting the Pineapple, the problem was solved. Not sure if it's valid in your particular case, but it could be worth checking. It's easier though to try to do the operation using ssh, so I would try that first rather than go for hardware serial (which requires a serial adapter and will most likely void warranty).

Link to comment
Share on other sites

OK found the solution. Its a workaround. SSH into the pineapple using the root password you setup (it actually saved it). Once there:

rm /etc/pineapple/setup_required

That removes the zero size flag that tell it that it must continue setup. Once I did that, it stopped trying to configure setup - and all of the items I had already put in were saved and working fine. Hope this helps someone.

Link to comment
Share on other sites

  • 2 weeks later...

It is ridiculous that Hak5 ships this pineapple from China without a working operating system. 

Upon receipt of the Pineapple Brick 7, the customer is tasked with an immediate "upgrade" of the firmware. It is NOT an UPGRADE. It is an initial install of the firmware.

Why can't this company get it together and install a working operating system on this product?

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...