Jump to content

C² behind reverse proxy logging internal IP instead of real client IP


reinaertvdc
 Share

Recommended Posts

I have my C² instance dockerized, with NGINX as a reverse proxy in front of it. My C² audit and server logs all look as follows:

2021-04-09 13:52:41 admin@172.19.0.3:43928 GET /api/apilog
2021-04-09 13:52:40 admin@172.19.0.3:43924 GET /api/settings/devices
2021-04-09 13:52:40 admin@172.19.0.3:43918 GET /api/settings/server/size
2021-04-09 13:52:40 admin@172.19.0.3:43912 GET /api/settings/client

My C² instance is always logging the internal IP address instead of the actual client IP address, meaning that any IP-related information is lost.

I've tried the C² -reverseProxy flag, along with passing the real client IP on through various headers, like X-Forwarded-For, but this has not helped.

Are forwarding headers currently supported in C²? If not, I'd love to see this added.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...