Jump to content

mdk4 on Mark VII from terminal


Recommended Posts

1 hour ago, chrizree said:

What kind of MDK4 attack are you trying to get to work? What have you tried so far when it comes to CLI?

I am trying to run a mdk4 deauth attack against just my router.  

I had tried mdk4 wlan1 d -b /root/blacklist

If I try and run a deauth attach via the module I can't figure out how to limit it to just one MAC. I would prefer to just use the modules as my command line skills are lacking 


Link to comment
Share on other sites

Doesn't that command throw a (rather long) error message back at you since the interface (wlan1) isn't in monitor mode? I can't in any way say that I'm a frequent user (or a user at all actually) of mdk4, but installing the module and its dependencies on my Mk7 wasn't all that successful. Everything looks OK when it's installed, but when running mdk4 from the command line of the Mk7 it just started attacking other APs than the one I had specified in the blacklist file (or at command line using -B). I did the same from one of my Kali boxes and that went all fine. So, I compared the mdk4 versions and the one that was installed along with the Mk7 module looked older than the one that was installed in Kali. So I removed the mdk4 package from the Mk7 and then downloaded a variant that has been made available by adde88/Zylla for the Mk7. When using that variant of mdk4 everything looked all fine. Apart from the CLI tests, also the Mk7 web GUI was successful running mdk4 (the "deauth attack mode" that is).

Link to comment
Share on other sites

opkg remove mdk4

wget https://github.com/adde88/openwrt-useful-tools/raw/packages-19.07_mkvii/mdk4_4.1-9_mipsel_24kc.ipk

opkg install ./mdk4_4.1-9_mipsel_24kc.ipk

which installs
MDK4 4.1 (according to the info you get from MDK4 when running it from CLI)

I.e. you shouldn't remove and reinstall the Mk7 MDK4 module itself, just leave that as it is. Just install a different version of MDK4 at command line on the Mk7.

Link to comment
Share on other sites

Starting to think I may have a hardware issue. I got some assistance updating the version of mdk4. I tried to run mdk4 wlan1mon wlam1mon d -B with SSID and -E with MAC and no results.  I only deauthorize myself from a second AP that was not listed.

Link to comment
Share on other sites

-B is BSSID, i.e. MAC address, not SSID (or ESSID) which is -E, you mixed them up, it's the other way around

    ATTACK MODE d: Deauthentication and Disassociation
      Sends deauthentication and disassociation packets to stations
      based on data traffic to disconnect all clients from an AP.
          -w <filename>
         Read file containing MACs not to care about (Whitelist mode)
          -b <filename>
         Read file containing MACs to run test on (Blacklist Mode)
          -s <pps>
         Set speed in packets per second (Default: unlimited)
         Enable full IDS stealth by matching all Sequence Numbers
         Packets will only be sent with clients' addresses
          -c [chan,chan,...,chan[:speed]]
         Enable channel hopping. When -c h is given, mdk4 will hop an all
         14 b/g channels. Channel will be changed every 3 seconds,
         if speed is not specified. Speed value is in milliseconds!
          -E <AP ESSID>
         Specify an AP ESSID to attack.
          -B <AP BSSID>
         Specify an AP BSSID to attack.
          -S <Station MAC address>
         Specify a station MAC address to attack.
          -W <Whitelist Station MAC address>
         Specify a whitelist station MAC.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...