Jump to content

Need to completely redo flash on keycroc! Filesystem is corrupt.


Recommended Posts

Hello. after months of bizarre problems with my KeyCroc, I finally realized that my flash filesystem is corrupt.

root@croc:~# e2fsck -fn /dev/nandd
e2fsck 1.42.12 (29-Aug-2014)
Warning!  /dev/nandd is mounted.
Warning: skipping journal recovery because doing a read-only filesystem check.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong (505705, counted=505574).
Fix? no

Free inodes count wrong (168264, counted=168259).
Fix? no

/dev/nandd: 44728/212992 files (0.1% non-contiguous), 346263/851968 blocks

Is there any way I can force an e2fsck during boot, or perhaps cause a complete rewrite/replacement of flash data? I have already tried reinstalling the latest firmware. I have also tried erasing the entire udisk and then copying over the flash file, before rebooting. The firmware does complete 100%, or at least it appears to. I also verified the sha256sum before applying it. It seems that my entire /lib/modules folder is missing.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...