Jump to content

VPN service to C2 works OK until opening SSH terminal to Hak5 device


hbackus
 Share

Recommended Posts

I run a VPN service to connect to the Internet. I can open my C2 instance OK and see my devices and stats OK. When I select a device, terminal, and try to open a SSH connection to the device I get the spinning circle icon  and never get the SSH session established. Any suggestion on how to keep my VPN session and be able to open a SSH session from withing my C2 instance would be appreciated.

 

Link to comment
Share on other sites

I think it would help to know more details about your setup? For example:

Is C2 server connected to the VPN server?

Or perhaps C2 is the VPN server? If you don't know what I mean here, just skip it.

If the VPN is separate from/external to the VPN, then is your computer connected to the VPN?

Also, are any of your Hak5 devices connected to the VPN?

Finally, if the VPN were disconnected, would any of the other components be on the same network?

I suspect a routing issue, but impossible to say with current information.

Please do not post any public or Internet-facing ip addresses or domain names in your response. Also, please redact any personally identifiable info.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...