Jump to content

Need C2 Download guidance - Complete Noob


Recommended Posts


I'm a complete noob at all of this stuff. My dad bought me some gear from this website and told me about it. He figured it would be a cool hobby. I'll be getting some of it in the mail soon.

I tried downloading the C2. I clicked on it (I have windows) and it opened and nothing happened. It was code and I don't know what it means.

I've done some googling and am learning about command prompts and trying to figure out my hostname, and learned about a VPS from the following video https://docs.hak5.org/hc/en-us/articles/360049663714-Quick-Deployment-on-Amazon-Lightsail

I'm also reading the following post https://forums.hak5.org/topic/44842-step-by-step-instructions/ and am still lost.

I'm completely lost.

Any help would be much appreciated. I am complete noob.

Thank you so much.

I start my CSC classes soon so maybe I'll have a better understanding after my first semester in school.


Link to comment
Share on other sites

OK this is my Hell0w0rld into the forum and Hak5 in general I just received my SharkJack, and am waiting on a Kismet Mark VII and a Rubber Ducky. In the mean time I was setting up my C2 server on a Ubuntu 20.04 VPS using Light Sail. I was able to get it up and running using :8080 using the -wget command to download, unzip, and install. I then wanted to setup the SSL version and this is where i ran into a problem. I have a domain and set the A record to my static IP and ran

sudo ./c2-3.0.2_amd64_linux -hostname example.org -https

It shows as [*] Running Hak5 Cloud C2

But then I try to enter the domain in FireFox (tried Incognito as well) and it gives me an unable to connect error, and it shows the proper Static IP but with :8080 still. I think there is an issue with the SSL certificate, and I don't think it is now should be pointed to :8080 after starting with -https. I have been spinning my wheels now for a few hours and am hoping there may be something I am missing that is just sitting in front of my face and hope maybe the experts here have some insight.

Sorry if this is long winded I normally avoid chat and social media since the old AOL days so this feels a bit weird and nostalgic at the same time 🙂

Thanks in Advance, and Hope down the line I can provide some help as well 😉


Link to comment
Share on other sites

I guess you have followed Darren's 3 videos on the topic (episodes 2701, 2702 and 2703). If you have, it should work. Have you tried any other browser, even on other devices? You shouldn't see the IP or 8080 anymore, seems like a browser issue at first but since you try an incognito window, you should get it working. Is your Lightsail VPS firewall configured to accept 443 traffic? You should get another kind of "behavior" in the case you haven't though.

Link to comment
Share on other sites

Man \﹏/ \﹏/ super helpful, Thank you. I tried Bing and it worked with the domain, not sure why, but maybe you have insight on why it would work with Bing and not work on Firefox or Firefox Incognito? With Firefox I still get

(Firefox can’t establish a connection to the server at Example.org:8080.)

I thought it might be a time issue with the domain change ( i.e. I set the A record yesterday) but I would think that that would be synced up between the browsers?

Anyways Thank you for the successful foray into the Forums 🙂

Link to comment
Share on other sites

With Bing, I guess you mean Edge, or?! It's for sure a Firefox thing if it works in other browsers. You could try to "force" refresh (bypass cache) of the page loading or clear cache and such.

- Hold down the Shift key and left-click the Reload button
- Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
- Press "Command + Shift + R" (Mac)

Could also be some addon/plugin that you might have active/installed. Difficult to say without having the "whole picture painted of the landscape".

Link to comment
Share on other sites

  • 3 weeks later...

I'm getting a related but different issue.

After getting everything set up and running without SSL I then try and follow video 2.

I add the A record to the domain name.

I run

./c2-*_amd64_linux -hostname myhostname.com -https

I get 

[*] Initializing Hak5 Cloud C2 v3.1.1
[*] Hostname: myhostname.com
[*] DB Path: c2.db

When I browse to myhostname.com I get a connection refused error.

When I browse to myhostname.com:8080 it connects but isn't encrypted. I feel like I'm missing something simple, like host firewall. The firewall in Lighsail is allowing 443, so not sure.

Any assistance is appreciated!

Link to comment
Share on other sites

I am still learning a ton about all this but if remember correctly there should be two more [*] actions in your example that are missing the last one being "[*] Running Hak5 Cloud2" . So it seems like it is not being fully loaded maybe,  try using sudo to run the "./c2-*_amd64_linux -hostname myhostname.com -https" command. Hopefully it helps but at least it wont hurt 🙂

Link to comment
Share on other sites

Thank you so much for the reply Handy Geek! I think that might have fixed it! I was able to carry on and get C2 running as a service, so I'm crossing my fingers that it is alive in the morning! Good luck, and thanks!

Link to comment
Share on other sites

Nice!!!! If it is not running in the morning there is the third video in the series (2703) that goes over ensuring it stays active persistently.  It took a little bit more work to get LightSail to keep the site active after I logged out or left the AWS site. But it is definitely worth it, I can not log in from my mobile device and manage the site on the go. If you are new to this like me, I have to say it is a lot to learn, but it is a lot of fun too. I use it to take my brain off learning CCNA lol

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...