Jump to content

Recommended Posts

Looking at Darren and Shannon's post below.  I attempted to set up Easy Tether Pro by connecting my smartphone with the Pineapple Mark VII, Has anyone gotten this to work?

The instructions work good until i get to the 10:30 minute mark.  There is not a install available for the CPU architecture for the MarkVII.  I have tried the latest version and  downloading older versions, but none seem to have the architecture of the MarkVII which is either "mips" or "MediaTek MT7628", however I'm not 100% sure that info i have found is correct.  So none of the installs work because the architecture is not compatible, hence can't get EasyTether to work.  Just wondering if anyone else has had this issue

 

 

Link to post
Share on other sites

Is there a specific reason to why you have to use a cable between the phone and the Mk7 and not simply use a hotspot on the phone to connect the Mk7 to?

Link to post
Share on other sites

Easy Tether Pro connects via USB cable or Bluetooth, but also requires the client device to have the EasyTether software for it to work.  I do not have a monthly hotspot plan on my phone.  I wanted to use the EasyTether method to avoid this.

Link to post
Share on other sites

Yes, I know that it’s how EasyTether works. I still don't get your use case scenario, but... anyway...

What do you mean with "monthly hotspot plan"? The hotspot is a built in feature in your Android phone. Just create a hotspot using the standard Android features/menus. Then connect the Pineapple to the hotspot using wlan2. It's then possible to connect to the Pineapple from the phone or any other device that is connected to the phone's hotspot.

This is independent of if the phone has a mobile internet connection or not, I'm now running (parallel to writing this) on a phone that has no internet at all, using its hotspot that the pineapple is connected to. I can connect to the pineapple from the phone itself and other devices that are connected to the phone's hotspot.

Another (perhaps more “natural”) way to access your pineapple is to use its management interface from the phone, but... as said... I can't really see what your use case scenario is. If you aren’t going to use the phone to let the pineapple have internet access, I can just guess what you are trying to accomplish.

If you still want to try to get EasyTether working you could try to match the pineapple with the correct files that might work for your particular scenario. If it works?! I don't know, I haven't tried it since I don't have the need for it since I have other ways to interact with the Pineapple, so you do this at your own risk.

If you run the following on the Pineapple Mk7

cat /etc/openwrt_release

you can see that it runs on ramips/76x8 and OpenWrt 19.07.3

Files that perhaps works for this architecture is available in one of the zip files below 

ssh into the Pineapple and run

wget http://www.mobile-stream.com/beta/openwrt/easytether-usb-tiny_0.8.9-5_openwrt-19.07.3.zip
or
wget http://www.mobile-stream.com/beta/openwrt/easytether-usb-openssl_0.8.9-5_openwrt-19.07.3.zip
(depending on what variant you are going to use)

unzip the downloaded file

The ipk file needed should be in ./19.07.3/ramips/mt76x8/

But, as I said, I haven’t tried this myself, so you might run into problems if you proceed. Be prepared for that scenario.

One sidenote: I don't know if you have downloaded/bought the EasyTether Pro that is linked in the Hak5 video you have been watching, but that links to EasyTether Pro by some company(?) called Polyclef Software. I don't know if there's any link between the two, but EasyTether is actually developed by Mobile Stream as far as I know.

Link to post
Share on other sites

Hi Chrizee,

Thanks for the detailed post.

For the use case scenario:

This is helpful because for people who have an unlimited data plan, but not an unlimited tether plan this scenario would be useful.  Easy tether is tethering, but not by the means of the traditional way.  If easy tether gave you the ability to make a hotspot out of it, it would be great because you wouldn't even need the Pineapple.

That command "cat /etc/openwrt_release" was very helpful, that helped pin-point which version to use for the install.

I was able to successfully install the correct version, however when you get to the point to activate EasyTether Pro on the Pineapple, it disconnects the Terminal session via Terminal on the Pineapple and I get the same result when attempting to do it via Putty.  Then once you re-connect EasyTether didn't work, which is frustrating.

the screen shots below are with the "tiny" version which has the extra line "/etc/easytether/adbkey: no such file or directory".  I have also tried the same steps installing the SSL version with the same result, just not with the "/etc/easytether/adbkey: no such file or directory" line.

Pineapple Terminal method

Pineapple-error

Putty Terminal method

putty-error

To your sidenote, Yes, i did use the same software mentioned in the video "EasyTether Pro" and paid the 10 bucks for the Pro version.  Well worth it for using a laptop

 

Link to post
Share on other sites

OK, I understand your limitations when it comes to your data plan/tether plan. I'm not used to such limitations where I live. An alternative could be to trick the provider in the way they limit things. I'm not sure if it's working in your specific case, but you could at least try if you feel for it and perhaps eliminating the need of EasyTether. Look at Glytch's videos on how to alter the TTL value.

https://www.youtube.com/watch?v=WHqlYILMhgg

https://www.youtube.com/watch?v=alMsu_tfZPE

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...