Jump to content

Bunny went into read only mode after a script


Recommended Posts

Hello - very new user here.  Been playing with some of the more innocent scripts and seems like one messed me up.

I ran the simple-usb-file-extractor on a Win10 computer and when reconnecting to my linux machine in arming mode, the filesystem was in read only mode... the permissions when mounted have a "+" at the end. Through some of the commands below I could remove this "+" but the file system is still read only.  I have rebooted, remounted, recovered multiple times.

I searched and tried:

Firmware recovery three times

sudo mount -o rw,remount /dev/sda  

<br />

sudo umount -f /dev/sda  
# and then 
sudo dosfsck /dev/sda

<br />

sudo setfacl -b /run/media/<username> 

<br />

sudo mount -o remount,uid=1000,gid=1000,rw /dev/sda 

Thanks so much for your time!

Link to post
Share on other sites

SOLVED

I guess I will leave this here in case it can help anyone.  I needed to select the correct options in

sudo dosfsck /dev/sda

in order for it to remove the "Dirty Bit" and clean the partition.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...