Jump to content

Newly received WiFi Pineapple ... error SSL_ERROR_RX_RECORD_TOO_LONG


Recommended Posts


I just received my WiFi Pineapple and I`m a noob with this stuff, so apologies in advance for the dumb questions, also english is not my first language.

After It asked for the initial configuration and automatically downloaded and updated the firmware, when I try to connect again it gives me the following error:


Failed secure connection An error occurred connecting to SSL has received a record that exceeded the maximum length allowed. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

I've tried to do a recovery following the guide in https://docs.hak5.org/hc/en-us/articles/360055166053-Firmware-Recovery , but it does not solve the problem. I've tried to modify the configuration in the browser (Firefox 84.00 and Chromium 87.0 running on a linux 5.9 machine under Manjaro ), which is supposed to be a big no-no, and it does not improve anything. I`ve also tried to do the connection trough the usb and got the same results.

Could any of you give a hand trying to solve it?

Thank you in advance

Link to comment
Share on other sites

Thanks for your help. I tried both protocols:

-the https, kept saying that there was an error in the record being too long.

-the http only showed a blank page and tried to load until it timed out.

I`ve reset the Pineapple three more times, and the last time I've got it working on the http protocol. I`m still puzzled about why it was giving my the blank page in http. About the https I guess it does not have it enabled.

Once again, thanks for your help

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...