Jump to content

Unable to connect to 172.16.42.1:1471


Recommended Posts

I just recently got a wifi pineapple nano. I got it all setup and everything was working as it should. Just today I went to connect it to my raspberry pi running kali. I run the wp6 script and it successfully detects the pineapple. I navigate to http://172.16.42.1:1471 and I get unable to connect. Firefox cant establish a connection to the server at 172.16.42.1:1471. I can successfully ping both  172.16.42.1 and 42.42 as well as establish a ssh connection to the pineapple. Does anyone know why it wont allow me to access the UI?

Link to post
Share on other sites

Have you tried connecting to the Nano with some other client than the Kali based Raspberry Pi?

If you ssh into the Nano and run ps ax | grep [n]ginx , does it show a running nginx process (or two actually, a master and worker process). Is the master process started with the /etc/nginx/nginx.conf file as a parameter?

If you cat the /etc/nginx/nginx.conf file, does it contain a server segment specifying port 1471 and server name pineapple?

These are things that normally shouldn't change at all, but just to make sure you have a running web server on the Nano to accept client requests.

Link to post
Share on other sites

Every time I try to connect my Nano up now it won't connect.  I run wp6.sh and get these errors below.  I have tried several versions of Ubuntu but still get the same message.  When I tried in Windows 10 by sharing the Network Connection, it just doesn't work.  Can anyone detect what is going on below from this Linux distro?

 

Specify Default Gateway IP Address: 192.168.1.1

    Settings saved.

    Saved Settings: Share Internet connection from enp3s0
    to WiFi Pineapple at enx00c0ca8dd6b8 through default gateway 192.168.1.1

    [C]onnect using saved settings
    [G]uided setup (recommended)
    [M]anual setup
    [A]dvanced IP settings
    [Q]uit

    ./wp6.sh: line 268: ifconfig: command not found
Detecting WiFi Pineapple......found.

         _ .           ___          \||/
       (  _ )_  <-->  [___]  <-->  ,<><>,
     (_  _(_ ,)       \___\        '<><>'
./wp6.sh: line 280: ifconfig: command not found
./wp6.sh: line 287: route: command not found
./wp6.sh: line 288: route: command not found

    Browse to http://172.16.42.1:1471

xubuntu@xubuntu:~/Desktop$

 

Link to post
Share on other sites

What versions of Ubuntu have you tried? The ifconfig command is used by the wp6.sh script file, but ifconfig isn't a part of later versions of Ubuntu per default. Hence the error messages that you get from the wp6.sh script file (and also adds to the fact that it doesn't work since there's no ifconfig command to bring up interfaces, etc.). If you don't want to rewrite the wp6.sh file yourself using the ip command (or such equivalent in newer Ubuntu versions), you can install ifconfig using the command below and see if the wp6.sh script gets a bit more successful. The same goes for the route command that also throws errors in your script output, it's a part of net-tools.

sudo apt install net-tools

Connecting using a Windows machine shouldn't be any problem. I normally don't use/access my Nano that way, but I hooked the Nano up to one of my Windows boxes and followed the instructions on Hak5 Docs (link below) and it worked without any problems at all.

https://docs.hak5.org/hc/en-us/articles/360010555473-Internet-connection-sharing-over-Ethernet-in-Windows

Edited by chrizree
Link to post
Share on other sites

Do they still sell Nanos?  I don't see them on Hak5???  Try and linux setup video by Darren.  I find it easier to troubleshoot networking issues on Linux.  I got mine working by setting the ip address on linux using ifconfig, resetting and flashing it.  Then it worked on both Windows and Linux.  Then I came home and now it is not connecting to the internet...but at least it is giving me the dashboard. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...