Jump to content

wifi pineapple nano wifi client interface not showing dongles


Grimx49
 Share

Recommended Posts

Hello,

Im hoping someone can help with this. My nano used to work with the usb wifi dongle I plugged in before the update. After I updated it started to be a little finicky.

I have tried rebooting & reconnecting after boot. It still does not show up although I can see it connected in the usb & storage window. It just will not show in interfaces. Only wlan1 shows.

I bought a new Dongle and its the same thing. So far I have tried 3 different adapters and its the same problem no matter if I try on Linux through VM, a dedicated linux computer or my windows pc.

Bus 001 Device 005: ID 0bda:818b Realtek Semiconductor Corp. RTL8192EU 802.11b/g/n WLAN Adapter
Bus 001 Device 013: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 014: ID 0b05:17d2 ASUSTek Computer, Inc. USB-AC56 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]

I even attempted to ssh into the nano and run an opkg update, but everything is up to date.

I have even factory reset the nano, tried without my sd card in. Nothing seems to be working. Any help would be greatly appreciated

 

Link to comment
Share on other sites

The RTL8812AU is known to produce issues with the Nano, it just resets/reboots when trying to bring the interface up. I have no current status for the other chipsets that you are listing, but I have adapters equipped with those chipsets so I could give them a try sometime in the near future if I get some time for it. The USB WiFi adapter that I'm successfully using with my Nano is based on Ralink RT5370 (the same that is sold in the Hak5 shop).

https://shop.hak5.org/products/ralink-usb-wifi-rt5370

Link to comment
Share on other sites

I forgot to mention, the original adapter was a Ralink RT5370. That was the one that became finicky after I updated to the latest firmware.

Now for some reason its the only dongle that does not appear in the usb & storage window. I figured it was burnt out or something but I am able to plug it into my computer running kali linux, and sure enough it appears there when I do ifconfig and am even able to use airodump with it....so completly lost on this one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...