Jump to content

Sharing an internet connection / connect using usb ethernet device


Recommended Posts

So when I am trying to configure the internet connection on the pineapple the only option that works is to have it directly connect to a wireless access point. When I click the other options it just links me to some video guide documentation, this 'documentation' was a complete waste of my time and contains nothing relevant. How can you go about sharing the connection from the connected laptop? Running linux and connected using the usbc ethernet connection currently.

Also some actual text documentation would be great folks instead of having to waste time watching videos.

Thanks

Link to post
Share on other sites

Same issue. Plus mine loves to tell me I'm not connected to the internet.  The browser time sync fails.  Missing ... when you go to dark theme. Only way to delete reports is through the terminal.  Makes this release seem rushed without proper beta testing. 

  • Like 2
Link to post
Share on other sites

Can we add an external USB wifi adapter to the USB port on the Mark7?  I believe the documentation said we could.  Well - I plug it in, reboot the device, delete my browser cache, refresh the Networking page, and wlan2 is the only option I have... The list of USB devices shows my external USB wifi adapter, but is not an option to use to connect to an SSID...  

 

Link to post
Share on other sites
11 hours ago, Phuture said:

Can we add an external USB wifi adapter to the USB port on the Mark7?  I believe the documentation said we could.  Well - I plug it in, reboot the device, delete my browser cache, refresh the Networking page, and wlan2 is the only option I have... The list of USB devices shows my external USB wifi adapter, but is not an option to use to connect to an SSID...  

Yes, you can - but please ensure it's a supported adapter. What adapter are you using? Which firmware version are you on?

  • Like 1
Link to post
Share on other sites
12 minutes ago, Phuture said:

I'm on 101 with approved usb wifi adapter Linksys AE6000 802.11a/b/g/n/ac Wireless Adapter [MediaTek MT7610U]. why do i only see wlan2 in the Networking tab?

The MT7610U isn't an "approved" (I assume you mean on the list of verified working adapters in the docs.) 

You will need to install kmod-mt76x0u via opkg, as this driver is not shipped in the firmware.

opkg update && opkg install kmod-mt76x0u

 

Link to post
Share on other sites

Disregard previous post as it's irrelevant now given that I installed kmod-mt76x0u via opkg with the command Foxtrot shared to no avail - Networking tab still only shows wlan2 despite showing my usb wifi adapter in the USB devices list.  This is after a reboot, then a firmware recovery and subsequent kmod update...

 

Link to post
Share on other sites
6 hours ago, Phuture said:

following this one last time- https://docs.hak5.org/hc/en-us/articles/360055166053

I imagine that Im going blind after all of this, but I don't know why i didn't notice this discrepancy during prior recoveries: which file should be used? mk7_recovery_1.0.1.bin OR upgrade-1.0.1.bin one is called out in the docs, the other is called out in the device screens

The first step in that docs article links you to the recovery image... That is the one that you use in the steps afterwards.

When the device reboots and you've verified it's your device by pressing the button on the unit, either use the OTA update mechanism or download the full firmware update from downloads.hak5.org and upload it.

Link to post
Share on other sites

DISCREPANCY = the first step in the doc links to a file, indeed. then, while performing the procedure from the doc, the user is presented with another link to a different file.  

the aforementioned discrepancy is now moot for me - I can no longer enter Recovery Mode.  I let go after 3 reds then launch my browser and am presented with everything i saw before shutting mark7 down/unplugging him.

Any further thoughts?  In response, can you pls provide the top 3 competitors to Hak5's Pineapple line in terms of functionality, reliability, cost, market share?

Link to post
Share on other sites

once a user succeeds in getting their wifi usb adapter to work in mark7, how does mark7 know what to use?   does it use my wifi usb  adapter or one of its builtin antennas?  is there a dropdown or some ability for the user to choose?

once a user succeeds in getting their wifi usb adapter to work in mark7, what does mark7 use it for?  for broadcoasting SSIDs?  for the open AP?  for sending deauth's?   is there a dropdown or some ability for the user to choose?


btw - sticking the cisco ae6000 in causes mark7 to flash blue and not respond.

 

Link to post
Share on other sites
4 hours ago, Phuture said:

DISCREPANCY = the first step in the doc links to a file, indeed. then, while performing the procedure from the doc, the user is presented with another link to a different file.  

I fail to see where the discrepancy in the documentation article you linked is? There is only one link to a direct file download. You're not required to download any more files to complete this process...

4 hours ago, Phuture said:

the aforementioned discrepancy is now moot for me - I can no longer enter Recovery Mode.  I let go after 3 reds then launch my browser and am presented with everything i saw before shutting mark7 down/unplugging him.

I'm not sure I follow your steps here. After 3 red flashes, the LED stays red. You're now in the bootloader recovery - not the OS. You should also (as the guide says) navigate to http://172.16.42.1 to access this interface, not http://172.16.42.1:1471

4 hours ago, Phuture said:

once a user succeeds in getting their wifi usb adapter to work in mark7, how does mark7 know what to use?   does it use my wifi usb  adapter or one of its builtin antennas?  is there a dropdown or some ability for the user to choose?

once a user succeeds in getting their wifi usb adapter to work in mark7, what does mark7 use it for?  for broadcoasting SSIDs?  for the open AP?  for sending deauth's?   is there a dropdown or some ability for the user to choose?

You can use correctly configured adapters for anything you would use it for normally... including full access over the command line. Tighter integration within the UI is a planned and in-progress feature addition.

4 hours ago, Phuture said:

btw - sticking the cisco ae6000 in causes mark7 to flash blue and not respond.

I don't own one of these to test with, but this description makes it seem like an upstream driver issue.

Link to post
Share on other sites

The doc says to d/l one file - the actual Recovery interface says to d/l another. https://prnt.sc/vbghd8

Okay, now Im seeing this screen: https://prnt.sc/vbgiaa I expect, in a few mins, to see a clean-slate Mark7 - NOT what happened the first and second attempts.
Okay, I'm opting wifi AP, not USBEthernet.

I'm opting to d/l firmware (upgrade-1.0.1.bin) and upload myself OR should i be starting with 1.0.0 and THEN using the upgrade-1.0.1 file - nowhere does it say such in firmware recovery doc. 

After 3 red flashes and letting go of the button, actually, the LED flashes rapidly then stays solid - there is mention of that NOWHERE. 

So usb wifi adapters have ZERO functionality in the GUI?

okay it rebooted with 1.0.1 file.  hoping for the best this time around!

Link to post
Share on other sites

After ~1 week of trying to get it to work correctly/as advertised, the Mark7 fails as advertised.  I emailed about a refund with no response yet.  When might I expect the full refund and instructions on how to return?

Link to post
Share on other sites
On 11/2/2020 at 7:03 PM, Phuture said:

After ~1 week of trying to get it to work correctly/as advertised, the Mark7 fails as advertised.  I emailed about a refund with no response yet.  When might I expect the full refund and instructions on how to return?

I hope for the same thing! Juste receive my Mark VII today and I have All the same problem. Nothing is Working well... 

  • Upvote 1
Link to post
Share on other sites
18 hours ago, PentestSatori said:

I hope for the same thing! Juste receive my Mark VII today and I have All the same problem. Nothing is Working well... 

Hold onto hope, PentestSatori - after posting here multiple times with no help at all from Hak5 support, I emailed them for refund and have not heard in about a week.  Finally, I had to execute a chargeback through my bank - still with no instructions on how to return this doorstop.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...