Jump to content

Recommended Posts

Hello!

We're happy to announce the release of 1.0.1 for the WiFi Pineapple Mark VII. Based on your invaluable feedback (especially the Beta channel testers, thank you!) - numerous improvements to PineAP, Recon, Settings and more have been made.

Be sure to check out the changes below and grab the new release by giving your WiFi Pineapple Mark VII an internet connection and going to "Settings > Check for Updates".

Changelog:

  • Setup
    • Improve screen real-estate on smaller mobile screens.
    • Button delay now says 4 seconds, to match the recovery wizard.
  • PineAP
    • Dramatically reduce the CPU percentage used by PineAP during idle and during scans.
    • Logging options can now be persistently stored in the browser.
    • Tweak the appearance of the logging options side bar.
    • A spinner now shows when PineAP is saving the users configuration.
    • Fixed an issue where the PineAP Source MAC option was not saving.
    • Fixed an issue where the PineAP Autostart functionality would not work correctly.
    • Fixed an issue where the PineAP Autostart toggle would not report a correct status.
    • Fixed a rare issue where PineAP would not start after being disabled.
    • Improved the settings save time.
  • Recon
    • Recon Table Columns can now be toggled to show or hide.
    • Added an OUI column to the Recon Table.
    • Scan duration choice is now remembered when you navigate away from Recon.
    • Fixed an issue introduced in Beta 2, where Recon would sometimes show an error if PineAP was not running.
    • Result cards are now clickable, instead of using a button to open the bigger view.
    • Result cards for Clients now render the timestamp in human-readable format.
  • Modules
    • Fixed an issue introduced in Beta 3 where modules would not start due to a missing SSL dependency.
    • Modules can now use PNG icons as well as SVGs.
  • Settings
    • Add censorship mode.
    • Keyboard shortcuts can now be enabled or disabled from the Advanced Settings tab.
    • Software Update will now accurately display when the selected update channel is closed.
    • Small text changes to Software Update.
    • Fixed an issue where Client Mode may not report an error correctly.
    • Improve reliability of Client Mode.
    • Client Mode settings are now saved automatically, and will re-connect on boot automatically.
    • Add an option to reinstall the current firmware if no update is found.
    • Greatly improve Network page for smaller mobile screens.
    • Greatly improve Settings page for smaller mobile screens.
  • Cloud C2
    • Improved the reliability of Recon scans.
  • Misc
    • Fix an issue where the Web Terminal would not connect when connected to the WiFi Pineapple via WAN.
    • Updated the Python library for WiFi Pineapple Mark 7 modules.
      • Fixed a rare issue where the internet connectivity check would fail despite having internet.
    • Add support for USB Ethernet adapters using the ASIX AX88179 chipset.
    • Add support for USB Ethernet adapters using the Realtek RTL8152 chipset.

As always, feedback is greatly appreciated, and you're encouraged to join the community to discuss!

  • Like 1
Link to post
Share on other sites

I just updated to 1.0.1 from the stable update channel and I am seeing a lot of issues.

  • If I enable PineAP the CPU usage goes up to 97%
  • Can't connect to the open wifi AP SSID
  • Broadcast APs don't seem to be broadcast
  • Wifi Recon returns no results

I was running 1.0.1 beta 4 before and everything was ok, apart from the very slow client network performance when connected to a broadcast PineAP SSID

Anyone else having issues?

 

Link to post
Share on other sites
2 hours ago, davidb62 said:

I just updated to 1.0.1 from the stable update channel and I am seeing a lot of issues.

  • If I enable PineAP the CPU usage goes up to 97%
  • Can't connect to the open wifi AP SSID
  • Broadcast APs don't seem to be broadcast
  • Wifi Recon returns no results

I was running 1.0.1 beta 4 before and everything was ok, apart from the very slow client network performance when connected to a broadcast PineAP SSID

Anyone else having issues?

 

@davidb62 Thanks for reporting that - Reinstalling the firmware should fix that for you.

Click on "Settings" then "Check for Updates", then "Reinstall Current Firmware".

  • Like 2
Link to post
Share on other sites
4 hours ago, Foxtrot said:

@davidb62 Thanks for reporting that - Reinstalling the firmware should fix that for you.

Click on "Settings" then "Check for Updates", then "Reinstall Current Firmware".

Yes, it's fixed now (we also chatted on discord)

I am also pleased to report the network throughput of the client when connected to an SSID broadcast by PineAP seems to be a lot better now

Thanks!

 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...