Jump to content

red led


Recommended Posts

You can always try to push for a return of the Ducky.

The only way I can see you could get more help here is to describe all the steps you make in detail (from very start to finish) so that ppl here can try to find something that's missing in the process. Other from that, only a "hands on" support scenario is the way forward as I see it, but that could be difficult if you don't have anyone close that can assist you irl.

Link to comment
Share on other sites

I will happily do so, and maybe it will also help others later on
I received the package and connected the sd card using the adapter I received. My computer opened the root of the card and there I put a bin file (I have attached a screenshot)  http://darren.kitchen/ducktest/inject.bin 
I then removed the adapter from the computer and plugged in the ducky, the light I received was a solid red light and remained so even when I inserted the sd card.
After contacting technical support I was asked to download a kit  https://downloads.hak5.org/api/devices/usbrubberducky/tools/ducky_flash_tools/1.0/ 
And even then the problem remained
From what I realized after some research and testing is that the problem is probably with the sd card, but also that I tried two more sd cards (a total of three including the one I got from the shipment) and in all of them the problem was the same.

I hope I explained myself properly and if I missed something I would love to complete the information, I was really patiently waiting for the ducky and I would really love to solve the problem and start using it.


Link to comment
Share on other sites

1 hour ago, Da31 said:

the light I received was a solid red light and remained so even when I inserted the sd card

this doesn't seem right... you should never insert the SD card *after* you have plugged in the Ducky, the SD card should be inserted in the Ducky when it's "cold", i.e. *before* plugging it in to the computer where the payload is to be used

Link to comment
Share on other sites

1. Connect the MicroSD card to your computer using the included MicroSD card reader (the card slides into the USB end).
2. Download the test inject.bin file from http://darren.kitchen/ducktest/inject.bin.
3. Move the downloaded test inject.bin file to the root of the MicroSD card.
4. Verify that filename is exactly "inject.bin", then safely eject the MicroSD card.
5. With the MicroSD card removed from the USB Rubber Ducky, plug the USB Rubber Ducky into your computer.
6. Note the LED indication.
7. With the USB Rubber Ducky connected to the computer, Insert the MicroSD card into the USB Rubber Ducky.
8. Note the LED indication.

Please see the demonstration video clip: https://youtu.be/vsqj9rFnHys

USB Rubber Ducky:
If the LED in step 6 was OFF, your USB Rubber Ducky firmware is damaged. Continue to Scenario 1.
If the LED in step 6 was RED, your USB Rubber Ducky firmware is working properly.

MicroSD Card:
If the LED in step 8 was RED, your MicroSD Card is damaged. Continue to Scenario 2.
If the LED in step 8 was Green, your MicroSD Card and USB Rubber Ducky firmware are working properly.

SCENARIO 1: Damaged USB Rubber Ducky Firmware

- Download the Ducky Flash Tools from https://downloads.hak5.org/api/devices/usbrubberducky/tools/ducky_flash_tools/1.0
- Using either the Windows program.bat, the Linux flash.sh, or Linux ducky-flasher utility, flash the USB Rubber Ducky with duck_v2.hex (from the ducky-flasher/Firmware/ directory).
- Update this ticket indicating the status of your USB Rubber Ducky firmware for further instructions.

SCENARIO 2: Working USB Rubber Ducky, Damaged MicroSD Card

- Format the MicroSD card with a FAT16 file system (MS-DOS) and perform the above test again
- Update this ticket indicating the status of your MicroSD card for further instructions.

This is the exact email I received from the support and in the steps they present they asked me to work as I mentioned (of course I also tried to connect the ducky along with the sd card) but in both cases the result was the same

Link to comment
Share on other sites

OK, according to the logic in that troubleshooting "howto" and your previous description of your scenario, the problem is linked to the SD card, not the Ducky. In what way have you formatted the SD card(s)? The way I linked in a previous post, or in some other way?

Link to comment
Share on other sites

Yes, right now I was sitting and trying to format with the tool you gave me, in addition I bought another sd card today and tried it too.
Unfortunately the result is the same and the support stopped answering me by email.
So I do not really know how to proceed

Link to comment
Share on other sites

It is so disparaging that when I asked about a product they answered me quickly and made sure I would be comfortable ordering. From the moment the product arrived and it did not work the support just stopped answering me, no one is trying to help once they have taken money from you.
I really did not expect this to happen

Link to comment
Share on other sites

  • 2 months later...
  • 5 months later...

It is definitely a problem with the micro sd card which is shipped with the rubber ducky. after I tried another micro SD card it worked like a charm. I'm wondering why hak5 is shipping this kind of micro SDs which are not working with the ducky wasting hours of my life with trouble shooting...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...