Jump to content

Mounting external drives?


Recommended Posts

I sure I'm close but does anyone know an easy way to mount a thumb drive or ssd to the M7? 

#mount -a ---did NOT work

#fdisk -l 


# mount -t  ext4 /dev/sda1 /mnt ---failed but I didn't expect it to work.

What file system does the pineapple use? Is there a better place to mount the drive than /mnt or /etc/fstab? 

Tried - # lsblk -f  

didn't work either but I found it here...https://openwrt.org/packages/pkgdata/lsblk so I tried this:



Stopping on my chain of dead ends and most likely incorrect assumption. Any help is appreciated. 


Link to comment
Share on other sites

  • 5 weeks later...

Hello Hike,

my 64GB USB 3 thumbdrive gets mounted automatically!

/dev/sda1 on /usb type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

Maybe connect it to a computer and check the file system?

Please post the output of dmesg.

Edit: I just realized you try to mount an NTFS filesystem using `-t ext4`, ext4 is a total different file system actually.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...