Jump to content

MK VII internal pin-out?

Go to solution Solved by Foxtrot,

Recommended Posts

I was curious if anyone knew what the4 pins internally on the MK VII are?

I  assumed it was USB and so tried a 4 pin header to USB-A cable with the thought of maybe shucking my Alfa, modding the case for a couple more antenna and having some 802.11AC, leaving the external port available for something else.

A POC test on a couple adapters with the cable on the 4 pin and nothing is being detected. The MK VII reboots if you remove/replace an adapter while hot, so I'm starting to think I'm flat wrong, or maybe I've got a short in the cable. Also flipping the header on the pins and I get no boot at all. 

Of course I'll keep tinkering, because that's what we do, but it would be nice to know if I was chasing my tail. 



Link to comment
Share on other sites

  • 2 years later...

I've been searching a bit and haven't found a real answer except for previous models but my question is piggybacking off of this. How can I connect to it using the serial? - Yes I know this is outside warranty and I am only looking because I have a semi broken pineapple. Thank you an advance and sorry to revive an old thread! 

Link to comment
Share on other sites

On 3/18/2021 at 7:13 PM, BitBang4Life said:

After giving up on the Mk VII for a while due to the device never going past the setup phase, I've decided to give it another go today. Alas, it didn't go much better. After re-flashing everything with 1.0.2, setup failed again with a "Config failed. Please try again". I noticed that the newly created management SSID was there, though... So the config must have been saved, right? I decided to go the UART route, and plugged the thing to a serial port only to find that a file named "setup_required" was hanging around /etc/pineapple. Removed that file, rebooted, bingo. Now I can log in with the password I've just created during the setup that "failed". All nice and good, but now it's time to connect to the internet! Problem now is that the "Select Inteface" list on the Wireless Client Mode is empty. Starting the PineAP fails. The only wireless interfaces on iwconfig are wlan0 and wlan0-1. No wlan1 or wlan2 to be found. Not sure if anyone else is having this issue, or if I'm doing something incredibly wrong, but I'm ready to re-flash my unit into something else. 

For the curious, with the USB ports facing right, the UART pinout is 3.3v - RX - TX - GND.  

I found this, can this be verified with any documentation or maybe a board layout w labels? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...