Jump to content

Nano resets when using USB wifi


exec4
 Share

Recommended Posts

Hello,

so I got a Pineapple Nano, running the latest firmware.

To use my ALFA AWUS036AC which uses an RTL8812AU chip, I installed a kernel mod:

opkg update
opkg install kmod-rtl8812au-ct

Now when I connect the adapter, wlan2 appears, I can run "ifconfig wlan2 up".
But as soon as I run "iwlist scan" the device reboots.

Also wlan2 has only 00 in the hwaddress.

I have now no Idea where to look first. How can I find out wheter it's a kernel panic?

The adapter is now connected using a powered usb hub, the hub draws exactly 0mA from the Pineapple, so this should not be a problem.

Thanks for your help.

Link to comment
Share on other sites

I can replicate the problem using the same setup. I then tried the same with one of my GL.iNet mini-routers that are running a slightly later release of the OpenWRT kernel. It wasn't successful but the ALFA adapter at least identified itself with a correct MAC address. The rest of the test was a "crash and burn" though. Not working at all so I guess it has something to do with the package/driver/kmod for the 8812AU chipset or kernel related or a combo (or something else). Perhaps something more needs to be installed to get it working. From previous experience, dependencies aren't always installed as per default in OpenWRT as one might be used to from more beefy OS:es/distros.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...