Jump to content

"Could not connect to internet." When Installing Depentencies

Go to solution Solved by Foxtrot,

Recommended Posts


I believe this issue has been solved. While different in cause than the previous issue reported in this thread (which was fixed in a 1.0.1 Beta), a recent change to our infrastructure for the online check at https://downloads.hak5.org/internet caused the request to fail, but not when being visited from a regular browser. This change has since been reverted and I have confirmed that the modules, and their dependencies, are downloading and installing as intended.

If you were having issues installing module dependencies, please ensure you have an internet connection to your WiFi Pineapple and try again now.


Link to comment
Share on other sites

  • 1 month later...

I just got my new mark 7 pineapple in the mail and was working on the modules trying to install the evilportal module. Im having the same issues as listed here where the modules will not install. I did install Nmap though and that worked just fine. it installed its dependency with no issues. Originally I was also getting the time sync error message but after a few restarts i have not seen that in a few hours. I am not able to get the evilportal dependency to install However, Voizdev has nearly identical issue to what im seeing so I attempted his fix of going to the /pineapple/modules/evilportal/module.py and running it. it gives the the following output before freezing for the 20 minutes i let it set before hitting ctrl+c.


root@mk7:/pineapple/modules/evilportal# python3 ./module.py
2021-03-20 16:13:45,646 - evilportal - DEBUG - Initializing module evilportal. (module.py:24)
2021-03-20 16:13:45,673 - evilportal - INFO - Starting module... (module.py:189)
2021-03-20 16:13:45,679 - evilportal - DEBUG - Binding to socket /tmp/modules/evilportal.sock (module.py:191)
2021-03-20 16:13:45,685 - evilportal - DEBUG - Listening on socket! (module.py:194)
2021-03-20 16:13:45,692 - evilportal - DEBUG - Calling 1 startup handlers. (module.py:196)


it sits here for as far as i can tell unlimited time. then when i ctrl+c out of it i get the following.

2021-03-20 16:22:07,984 - evilportal - WARNING - Error deleting socket or pid file: [Errno 2] No such file or directory: '/tmp/modules/evilportal.pid' (module.py:173)
2021-03-20 16:22:07,991 - evilportal - INFO - Shutting down module. Signal: 2 (module.py:175)
2021-03-20 16:22:07,997 - evilportal - WARNING - An os error occurred: [Errno 9] Bad file descriptor (module.py:216)


not sure if there is anymore information that I can give to help out with this. 


Link to comment
Share on other sites

  • 3 weeks later...
  • 5 months later...
On 9/30/2020 at 12:49 AM, newbi3 said:

This should now be fixed in firmware version 1.0.1 Beta 3 and newer. If anyone has issues going forward please report it.


Fw 1.1.1


I'm able to ping example.com but the network_test.py file is returning false.

After editing the url from example.com to https://example.com it returned true. Nevertheless i still can't install dependences (i'm getting the same error)

I'd love to hear some ideas on how to get back on track :)


Another thing noticed is that the time is not correct. Currently it's 15:00 and date returns 13:00 (probably due to the winter-summer times)

Link to comment
Share on other sites

  • 6 months later...

The dependencies install without issue on 2.0.0 beta.2022031113421, but did anyone mange to get one of Cleo's portals running? When I start the webserver and "preview", I get an error  "The webpage at might be temporarily down or it may have moved permanently to a new web address."?

Chrome inspect:

Failed to load resource: the server responded with a status of 401 (Unauthorized)

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

When pressing Preview:

ERROR TypeError: Cannot read properties of null (reading 'forEach')
at e._next (main.d403336.js:1:5502058)
at e.__tryOrUnsub (main.d403336.js:1:1015527)
at e.next (main.d403336.js:1:1014692)
at e._next (main.d403336.js:1:1013789)
at e.next (main.d403336.js:1:1013460)
at e.next (main.d403336.js:1:1019100)
at t.logout (main.d403336.js:1:2680311)
at t.doLogout (main.d403336.js:1:5758732)
at Object.handleEvent (main.d403336.js:1:5761542)
at Object.handleEvent (main.d403336.js:1:1266569)
  pl @ main.d403336.js:1

Pressing LOG:


ERROR TypeError: Cannot read properties of undefined (reading 'error')

at eval (evilportal.umd.js:581:30)

at eval [as _complete] (evilportal.umd.js:281:17)

at e.n (main.d403336.js:1:1015286)

at e.__tryOrUnsub (main.d403336.js:1:1015527)

at e.complete (main.d403336.js:1:1015420)

at e._complete (main.d403336.js:1:1013925)

at e.complete (main.d403336.js:1:1013624)

at e._complete (main.d403336.js:1:1013925)

at e.complete (main.d403336.js:1:1013624)

at e._complete (main.d403336.js:1:1013925)


My date and time are ok, ping example.com is good, internet_check.py results true

Edited by Sgt.Foose
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...