Jump to content

Another general connection issue - wired working just fine!


Recommended Posts

Hi all. I've searched through approximately 60 pages on this topic, checked out various websites, watched youtube tutorials and still coming up a blank, although I've learnt a fair bit of other info in the process!

Set up - nano / laptop / iPhone -works fine, can get full access to pineapple on iphone - bingo!

Set up 2 , nano, usb power pack (got one powerful enough to run the pineapple) Got the correct railink usb dongle and got blue light and  the pineapple comes up on the wifi devices list - unable to connect either via phone or laptop.

Set up 3 - as client (all settings correct when wired to laptop in the networking page, client mode, WLAN2 for the dongle, iPhone hotspot and password set up. Default interface updated.

Iphone identifies as hotspot and the 'link' symbol appears - I can access via the phone.

So, wired connections I have full functionality, can access updates, modules, perform scans, add notes etc etc but I'm trying to set up as a mobile device with minimum extra kit,

Ideally, the pineapple connected just to the railink and battery, tucked into the pouch and then use the phone to control it / view scan etc etc.

Am I missing a vital link? does the pineapple need the laptop to act as its internet connection (won't have one if wandering about on target)

Do I need to get another item like a wifi router to connect the pineapple to? 

I thought it was passive and could work without internet connection.

Is it the iPhone just blocking it somewhere. Do I switch to android now and be done with it? 

Whats the best minimalist (I'm talking pockets, not a tactical bag!) set up you guys are using? 

Thanks for looking and if anyone has any questions on the physical side I'm well versed in that and happy to help



Link to comment
Share on other sites

Might have fixed this. Stumbled across another thread. Now got nano connected to battery and usb WiFi dongle.

I reset the nano and in the setup where I’d set ‘allow’ I changed it to ‘deny’ - can’t find the original post / poster but thank you for putting down how you did it!

Connected to laptop

Held down reset button for 7 seconds

Waited (nervously) while the blue light flashed - for quite some time.

When light went solid I put the ip 172 etc... into the search and the set up page popped up immediately.

Followed all steps and changed access to deny for both drop down options.

Got a warning about access to the pineapple, should have took more notice of this but was amazed that it was working and I’d not fried it not knowing what I’m doing!

Accepted the T&C and it was straight in.

Performed recon scan which worked and played about with the settings, all seemed to change. 

Seemed a bit slow but in the manual it does say that it may be a bit slower.

Just got to test it out in the real world.

Still be interested in how people set this up discreetly for a more mobile deployment. Hope this helps someone




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...