Jump to content

Recommended Posts

It extends the back of the case with a flush mounting. I'll post the industrial design renderings once we finalize, before it goes into injection molding. In the meantime, if you have an adapter there's 5 GHz support out of the box for compatible chipsets. See https://docs.hak5.org/hc/en-us/articles/360054071133-Compatible-802-11ac-adapters

  • Like 1
Link to post
Share on other sites

Can anyone confirm Alfa AWUS036ACM works with the Mark VII?  

I know its listed as compatible, but a few people, on amazon, are complaining about non-existent Linux drivers.  

In the past I've have great luck with Alfa's but this is the first one I'm seeing that doesn't explicitly call out Linux, only MAC and Windows....

https://store.rokland.com/products/alfa-awus036acm-802-11ac-dual-band-2-4-5-ghz-wifi-usb-adapter

 

Take care!

Link to post
Share on other sites

I think that if Hak5 has the Alfa adapter listed as compatible, it will work. I guess the reason why many are complaining about lack of Linux support is that those comments are "historical" (i.e. rather old) since the MT7612U chipset (that the AWUS036ACM is built around) is supported in newer kernels. I have a couple of Aukey WF-R13 (with the MT7612UN chipset) and they work "out of the box" in Ubuntu and fresh releases of Kali Linux along with for example airodump-ng in monitor mode. Even MediaTek themselves lists Linux as a working operating system on the MT7612U chipset info page:

https://www.mediatek.com/products/broadbandwifi/mt7612u

  • Like 1
Link to post
Share on other sites
11 minutes ago, chrizree said:

I think that if Hak5 has the Alfa adapter listed as compatible, it will work. I guess the reason why many are complaining about lack of Linux support is that those comments are "historical" (i.e. rather old) since the MT7612U chipset (that the AWUS036ACM is built around) is supported in newer kernels. I have a couple of Aukey WF-R13 (with the MT7612UN chipset) and they work "out of the box" in Ubuntu and fresh releases of Kali Linux along with for example airodump-ng in monitor mode. Even MediaTek themselves lists Linux as a working operating system on the MT7612U chipset info page:

https://www.mediatek.com/products/broadbandwifi/mt7612u

Thanks for the knowledge and link!!

Link to post
Share on other sites
4 hours ago, jholbrookftl said:

are there any instructions on how to get the exterior wireless adapters to work? i plug in my alfa adapter and it does not even power on.

Mine won't light, but it finally showed up under lsusb and ifconfig once I made sure the Mk VII had 2A  and used a USB splitter to supplement power to the AWUS036ACM. The splitter might not be necessary for the Alfa, but I'll have to go back and test it later tonight. 

Link to post
Share on other sites
8 minutes ago, DaddyMACaddress said:

Mine won't light, but it finally showed up under lsusb and ifconfig once I made sure the Mk VII had 2A  and used a USB splitter to supplement power to the AWUS036ACM. The splitter might not be necessary for the Alfa, but I'll have to go back and test it later tonight. 

thanks, i'll give this a shot tomorrow, i was fairly certain i had the full 2A but will confirm tomorrow.

 

Link to post
Share on other sites
On 9/14/2020 at 11:19 AM, mako7c4 said:

Can anyone confirm Alfa AWUS036ACM works with the Mark VII?  

I know its listed as compatible, but a few people, on amazon, are complaining about non-existent Linux drivers.  

In the past I've have great luck with Alfa's but this is the first one I'm seeing that doesn't explicitly call out Linux, only MAC and Windows....

https://store.rokland.com/products/alfa-awus036acm-802-11ac-dual-band-2-4-5-ghz-wifi-usb-adapter

 

Take care!

I tested it with kali and works great, better than AWUS036ACH which doesnt work with kali at all. and it seemed like doing something in pineapple except there is no way to choose it for different tasks. so unless they add the feature which you can choose any radio for any task I guess you wont get any benefit

Link to post
Share on other sites

A bit off topic, but regarding ALFA adaptes and Kali Linux, I have the AWUS036AC (Realtek RTL8812AU, same chipset as the AWUS036ACH), the AWUS036ACS (Realtek RTL8811AU) and the AWUS1900 (Realtek RTL8814AU) and they all work in Kali Linux using realtek-rtl88xxau-dkms

Check to really see that the adapter is working or not with a fully updated version of the latest release of Kali and installed adapter support as per below

Install support for the adapter
apt install realtek-rtl88xxau-dkms

Attach the adapter to the PC

Run lsusb and iwconfig to see that the adapter is identified properly in the system

Assuming the adapter is identified as wlan1...

Disable the interface
ip link set wlan1 down

Set the interface in montitor mode
iwconfig wlan1 mode monitor

Enable the interface again
ip link set wlan1 up

Try listening in the air with the adapter/interface to verify that it is working
airodump-ng wlan1 --band ag -M -U --wps --beacons -w capfile01

 

Link to post
Share on other sites
On 9/11/2020 at 11:09 AM, Darren Kitchen said:

It extends the back of the case with a flush mounting. I'll post the industrial design renderings once we finalize, before it goes into injection molding. In the meantime, if you have an adapter there's 5 GHz support out of the box for compatible chipsets. See https://docs.hak5.org/hc/en-us/articles/360054071133-Compatible-802-11ac-adapters

Darren, will this work with the Kismet Case? I would like to know if it does or doesn't, before I gut my Pineapple Wifi MKVII and toss the old case.

Link to post
Share on other sites
On 9/11/2020 at 11:09 AM, Darren Kitchen said:

It extends the back of the case with a flush mounting. I'll post the industrial design renderings once we finalize, before it goes into injection molding. In the meantime, if you have an adapter there's 5 GHz support out of the box for compatible chipsets. See https://docs.hak5.org/hc/en-us/articles/360054071133-Compatible-802-11ac-adapters

Hey @Darren Kitchen has the MKVII module made it out of design yet?

Link to post
Share on other sites
  • 1 month later...
On 9/14/2020 at 9:23 PM, DaddyMACaddress said:

Mine won't light, but it finally showed up under lsusb and ifconfig once I made sure the Mk VII had 2A  and used a USB splitter to supplement power to the AWUS036ACM. The splitter might not be necessary for the Alfa, but I'll have to go back and test it later tonight. 

mine does not work no matter what i do. you just plugged it up and it eventually worked?

Link to post
Share on other sites
  • 1 month later...

I just hope it’s not like my AWUS036AC that thing was horrible to use, but I have faith in brother Darren so we will see. I order my markvii yesterday and excited to see what it can do. I bought this due to power consumption by my pc, when I turn it on all the light in the house dim......... lol jk

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...