Jump to content
entropy1024

Croc not connecting to WiFI

Recommended Posts

I can't get the Key Croc to connect to WiFi.

I have added the SSID and password in the config file and unplugged/re seated the croc. However it does not connect to the network. Please see below

DUCKY_LANG uk
WIFI_SSID mywifi
WIFI_PASS mypassword
SSH ENABLE
DNS 8.8.8.8 4.2.2.2

If I load the payload to return the IP address and then type __crocctl-ipinfo it just returns an empty line.

Share this post


Link to post
Share on other sites

This applied to any WIFI_SSID or WIFI_PASS – if you have special characters keep in mind those values are interpreted by bash so they would need to be escaped. For example:

P@$$w0rd!! would be P\@\$\$w0rd\!\!

Share this post


Link to post
Share on other sites
45 minutes ago, spywll said:

This applied to any WIFI_SSID or WIFI_PASS – if you have special characters keep in mind those values are interpreted by bash so they would need to be escaped. For example:

P@$$w0rd!! would be P\@\$\$w0rd\!\!

My original user and pass only had upper/lower/numbers and periods. Are periods considered special characters?

As a test I changed the SSID and testtest and the pass to password123. Same results, no connection.

Share this post


Link to post
Share on other sites

Some characters have one meaning in regular expressions and completely different meanings in other contexts. For example, in regular expressions, the dot (.) is a special character used to match any one character. In written language, the period (.) is used to indicate the end of a sentence. In mathematics, the decimal point (.) is used to separate the whole part of a number from the fractional part.

Regular expressions first evaluates a special character in the context of regular expressions: if it sees a dot, then it knows to match any one character.

For example, the regular expression 1. matches:

  • 11
  • 1A

The regular expression 1.1 matches

  • 111
  • 1A1

If you were to provide an IP address as a regular expression, you would get unpredictable results. For example, the regular expression 0.0.0.0 matches:

  • 0102030
  • 0a0b0c0

In order to tell regular expressions to see the dot in its original context as a separator for the different parts of the IP address and not as a special character used to match any other character, you need to provide a signal to that effect. The backslash (\) is that signal. When regular expressions sees a backslash, it knows that it should interpret the next character literally. A regular expression to match the IP address 0.0.0.0 would be:

0\.0\.0\.0

Use the backslash to escape any special character and interpret it literally; for example:

  • \\ (escapes the backslash)
  • \[ (escapes the bracket)
  • \{ (escapes the curly brace)
  • \. (escapes the dot)   

hope this helps 

iam still new to programming so if i give you the rong info iam sorry 

i love to learn programming 🙂

Share this post


Link to post
Share on other sites
On 6/30/2020 at 4:43 PM, entropy1024 said:

My original user and pass only had upper/lower/numbers and periods. Are periods considered special characters?

As a test I changed the SSID and testtest and the pass to password123. Same results, no connection.

Same problem here! I have tried simple password too. This is my config.txt:

DUCKY_LANG de
WIFI_SSID mywifi
WIFI_PASS mypassword12345
SSH ENABLE

 

Share this post


Link to post
Share on other sites

After testing with different SSID and passwords I can say:

This configuration is working:

DUCKY_LANG de
WIFI_SSID mywifi
WIFI_PASS mypassword12345
SSH ENABLE

This configuration ist not working:

DUCKY_LANG de
WIFI_SSID mywifi
WIFI_PASS mypassword1234\!5
SSH ENABLE

So im my network your solution with the backslash is not working!!!

The network password is set to mypassword1234!5

Share this post


Link to post
Share on other sites

Just have to ask 

are you running the latest firmware and can you get into arming mode and look at your log files how far are you for you access point just little things to look for

I have the same problem with my Croc i can not connect to my wifi pineapple nano to wifi but i can connect to my home access point to wifi

I thinking the croc has problems with some access point then others i don't know

Share this post


Link to post
Share on other sites
7 minutes ago, spywll said:

Just have to ask 

are you running the latest firmware and can you get into arming mode and look at your log files how far are you for you access point just little things to look for

I have the same problem with my Croc i can not connect to my wifi pineapple nano to wifi but i can connect to my home access point to wifi

I thinking the croc has problems with some access point then others i don't know

Does the croc work with 2.4 & 5GHz?

Share this post


Link to post
Share on other sites
15 hours ago, entropy1024 said:

I thinking the croc has problems with some access point then others i don't know

I'm thinking that the croc has problems with some access points. e.g. the Raspberry Pi is using the file wpa_supplicant.conf, you have to copy to the root partition. During the booting process,  the file will be saved to the Pi. IMHO, that is a better solution, than to store the clear text password in config.txt

From my point of view, the "backslash solution" in the config.txt should  not be the preferred way to configure the croc.

Share this post


Link to post
Share on other sites

I found a solution for my wifi network. I connected via serial interface to croc and checked /etc/wpa_supplicant.conf. Silly, the Backslash was in the Password. This is, of course, not working. So a removed the backslash in the config.txt like this:

DUCKY_LANG de
WIFI_SSID mywifi
WIFI_PASS mypassword1234!5
SSH ENABLE

And guess what? It works for me... 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...