Jump to content

Screen Crab : Solid Cyan - no capture


Floater
 Share

Recommended Posts

Hi

Got my Screen crab and after following the instructions gets stuck on solid cyan status without capturing any screenshots to microSD. I am not using the wifi/C2 version just local on the micro SD

I have tried different resolutions on 1080 1920x1080 and lower

And even changed the capture interval from 5 to 20

Would appreciate your help

My config:

LED ON

CAPTURE_MODE IMAGE

CAPTURE_INTERVAL 20

STORAGE FILL

BUTTON EJECT

DEBUG_LOG ON

 

And captured the log:

 

Util:        exec [stop adbd]|Util:   stop adbd shell exited value: 0|Util:        exec [stop logd]|Util:    stop logd shell exited value: 0|Util:      exec [source system/bin/crab && upgrade_check_on_boot]|Util:            Service start shell exited value: 0|Util:      exec [source /system/bin/crab && do_gpio_setup && leds_off]|Mirror: NEW HDMI Status; Input: false|Mirror:      HDMI REMOVED|Mirror:             PREVIEW STOPPED|Util:              RunThread shell exited value: 0|Util:                exec [source /system/bin/crab && upgrade_framework 1.0.6]|Util:         crabframeworkupgrade shell exited value: 0|CrabFramework:            Crab framework up to date|Util:              exec [source /system/bin/crab && red]|ShellThread:            setCPU Shell Thread Starting|Util:           exec [source /system/bin/crab, source /system/bin/crab && sleep 120 && do_cpu_setup]|Util:               Main setLEDsNow() shell exited value: 0|Util:     exec [source /system/bin/crab && wait_for_sd_location]|Util:             waitforSD shell exited value: 0|Util:        exec [source /system/bin/crab && led_off]|Util:         Main setLEDsNow() shell exited value: 0|SDREADER:      NO FILE AT PATH|RunThread:           ERROR LOADING C2 DEVICE CONFIG|RunThread:             Loading Crab Config from SD|Util:                exec [source /system/bin/crab && locate_sd && touch /storage/8832-E920/version.txt && echo 1.0.6 > /storage/8832-E920/version.txt]|Util:    versionfile shell exited value: 0|CrabConfig:        CONFIG OPTION LED|CrabConfig:               CONFIG ARG ON|CrabConfig:    LED MODE CONFIG OPTION SET TO: ON|CrabConfig:      CONFIG OPTION CAPTURE_MODE|

CrabConfig:        CONFIG ARG IMAGE|CrabConfig:            CAPTURE MODE CONFIG OPTION SET TO: IMAGE|CrabConfig:                CONFIG OPTION CAPTURE_INTERVAL|CrabConfig:           CONFIG ARG 20|CrabConfig:      CAPTURE INTERVAL CONFIG OPTION SET TO: 20|CrabConfig:                CONFIG OPTION STORAGE|CrabConfig: CONFIG ARG FILL|CrabConfig:              STORAGE MODE CONFIG OPTION SET TO: FILL|CrabConfig:          CONFIG OPTION BUTTON|CrabConfig:     CONFIG ARG EJECT|CrabConfig:               BUTTON MODE CONFIG OPTION SET TO: EJECT|CrabConfig:           CONFIG OPTION DEBUG_LOG|CrabConfig:          CONFIG ARG ON|CrabConfig:    DEBUG LOG CONFIG OPTION SET TO: ON|CrabConfig:              WIFI IS NOT SET IN CRAB CONFIG|CrabConfig:   WIFI CONFIG MISSING, ENSURING WIFI DISABLED|Util:             exec [source /system/bin/crab && disable_wifi]|Util:     wifi config shell exited value: 0|SDREADER:                NO FILE AT PATH|

Util:        exec [source /system/bin/crab && magenta]|Util:           Main setLEDsNow() shell exited value: 0|Util:     exec [source system/bin/crab && wait_five_for_button_press]|Util:  startup image mode listener shell exited value: 0|Util:   exec [source system/bin/crab && wait_five_for_button_press]|Util:       startup video mode listener shell exited value: 0|Util:        exec [source /system/bin/crab && magenta]|Util:           Main setLEDsNow() shell exited value: 0|Util:      exec [source /system/bin/crab && led_off]|Util:              Main setLEDsNow() shell exited value: 0|

SDWatch:            SD Watch Thread Starting|Util: exec [source /system/bin/crab, watch_sd_location]|ButtonListener:                Button Listener Thread Starting|Util:      exec [source /system/bin/crab, wait_for_button_press]|RunThread:                C2 WIFI IS DISABLED, NOT RUNNING|LEDRunner:            LED Runner Thread Starting|Util:             exec [source /system/bin/crab, led_off]|Util: LEDRunner shell exited value: 0|RunThread:      STARTING NEW CAPTURE THREAD|CaptureThread:             CAPTURE THREAD START|CaptureThread:           Signal Check request sent|Mirror:                REQUEST RECEIVED|Mirror:       NOSIGNAL|Mirror:        Response sent:NOSIGNAL|CaptureThread:         Response:NOSIGNAL|CaptureThread:    NO VIDEO SIGNAL|CaptureThread:         STARTING IMAGE CAPTURE|Util:                exec [source /system/bin/crab && get_current_temp]|Util:        tempcheckexit value: 0|

Util:        tempcheckshell output : 60879|CaptureThread:               CURRENT TEMP: 60879|Util:       exec [source /system/bin/crab && get_next_capture]|Util:    GetNextCapexit value: 0|Util:    GetNextCapshell output : /storage/8832-E920/LOOT/66|CaptureThread:  Capture Request Sent/storage/8832-E920/LOOT/66.jpg|Mirror: REQUEST RECEIVED|Mirror:        NOSIGNAL|Mirror:        Response sent:NOSIGNAL|CaptureThread:         Response:NOSIGNAL|

Util:        exec [source /system/bin/crab, white]|Util:        exec [source /system/bin/crab && no_signal_log]|Util: LEDRunner shell exited value: 0|Util:       NoSignalLog shell exited value: 0|CaptureThread:            CRAB HAS NO VIDEO SIGNAL|

CaptureThread: capture interval 20000ms|CaptureThread:          Time spent capturing 194ms|

CaptureThread: Capture sleep 19806ms|

Util:        exec [source /system/bin/crab && get_next_capture]|Util:         GetNextCapexit value: 0|Util:    GetNextCapshell output : /storage/8832-E920/LOOT/67|CaptureThread:               Capture Request Sent/storage/8832-E920/LOOT/67.jpg|Mirror:           REQUEST RECEIVED|Mirror:       NOSIGNAL|Mirror:        Response sent:NOSIGNAL|CaptureThread:               Response:NOSIGNAL|

Util:        exec [source /system/bin/crab && no_signal_log]|Util: NoSignalLog shell exited value: 0|CaptureThread:                CRAB HAS NO VIDEO SIGNAL|CaptureThread:    capture interval 20000ms|

CaptureThread: Time spent capturing 195ms|CaptureThread:    Capture sleep 19805ms|

Util:        exec [source /system/bin/crab && get_next_capture]|Util:         GetNextCapexit value: 0|Util:    GetNextCapshell output : /storage/8832-E920/LOOT/68|CaptureThread:               Capture Request Sent/storage/8832-E920/LOOT/68.jpg|Mirror:           REQUEST RECEIVED|Mirror:       NOSIGNAL|Mirror:        Response sent:NOSIGNAL|CaptureThread:               Response:NOSIGNAL|

Util:        exec [source /system/bin/crab && no_signal_log]|Util: NoSignalLog shell exited value: 0|CaptureThread:                CRAB HAS NO VIDEO SIGNAL|CaptureThread:    capture interval 20000ms|

CaptureThread: Time spent capturing 480ms|CaptureThread:    Capture sleep 19520ms|

Util:        exec [source /system/bin/crab && get_current_temp]|Util:        tempcheckexit value: 0|Util:      tempcheckshell output : 53727|CaptureThread: CURRENT TEMP: 53727|Util:       exec [source /system/bin/crab && get_next_capture]|Util: GetNextCapexit value: 0|Util:    GetNextCapshell output : /storage/8832-E920/LOOT/69|CaptureThread: Capture Request Sent/storage/8832-E920/LOOT/69.jpg|Mirror: REQUEST RECEIVED|Mirror:            NOSIGNAL|

Mirror:  Response sent:NOSIGNAL|CaptureThread:         Response:NOSIGNAL|Util:          exec [source /system/bin/crab && no_signal_log]|Util:            NoSignalLog shell exited value: 0|CaptureThread:            CRAB HAS NO VIDEO SIGNAL|

CaptureThread: capture interval 20000ms|CaptureThread:          Time spent capturing 404ms|

CaptureThread: Capture sleep 19596ms|

Util:        exec [source /system/bin/crab && get_next_capture]|Util:         GetNextCapexit value: 0|Util:    GetNextCapshell output : /storage/8832-E920/LOOT/70|CaptureThread:               Capture Request Sent/storage/8832-E920/LOOT/70.jpg|Mirror:           REQUEST RECEIVED|

Mirror:  NOSIGNAL|Mirror:        Response sent:NOSIGNAL|CaptureThread:         Response:NOSIGNAL|Util:          exec [source /system/bin/crab && no_signal_log]|Util:            NoSignalLog shell exited value: 0|

CaptureThread: CRAB HAS NO VIDEO SIGNAL|CaptureThread:    capture interval 20000ms|CaptureThread:          Time spent capturing 464ms|

CaptureThread: Capture sleep 19536ms|

Util:        ButtonListener shell exited value: 0|ButtonListener:       Button Listener Thread Complete|RunThread:  MAIN CALLBACK: BUTTON|RunThread:  SOFT RESTART: false|RunThread:            STOPPING: false|RunThread:    RUNNING?: true|RunThread:     Button pushed, STOPPING CRAB|RunThread:    Stopping crab: Button Pushed|

Link to comment
Share on other sites

  • 1 month later...

This occurs on one of my systems also. It still occurs if I reverse the HTMI cables on the Crab. The funny thing is, the video displays perfectly on monitor, but C2 says the crab is waiting for a signal. The problem seems to go away if I use a different monitor. Oddly enough, the TV I was using that has the issue also gives me problems on my Raspberry Pi 4 - The Pi never detects a device on that HDMI interface, and nothing is displayed on the TV. At least with the Crab, I can use the TV.

 

On a semi-related note: My TV doesn't receive the HDMI Audio signal when the Crab is in the mix, but works fine when I remove the Crab from the equation. I'm not sure if this is normal - the Crab might not be designed to relay HDMI audio.

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...