Jump to content
MorganG

WiFi Pineapple TETRA disconnects from Cloud C2 server after 15 minutes

Recommended Posts

I have a new install of Cloud C2 and a WiFi Pineapple.  I've just been tweaking the configuration, etc. when I noticed that the Pineapple shows offline in the C2 server after about 15 minutes (the exact time varies, sometimes it can be longer).  Each time it happens, all indications is that the Pineapple is continuing to function fine.  I can log it via web or SSH, stop and start PineAP, make configuration changes, etc.  The Pineapple can ping the C2 server by name.  If I reboot the Pineapple it reconnects to the C2 server, but that's the only way I can figure out to get it to reconnect.  Obviously this is less than ideal.

I've tried searching the forums and Google for any similar problem and can't find anything similar.  I'm also having an issue with the Recon function on C2 working at all, but I posted about that one separately as others have reported that one.  Any help or hint at what could be wrong would be greatly appreciated.

I'm running Cloud C2 v2.1.2 Pro Edition on Windows Server 2016 build 1607 and WiFi Pineapple TETRA with firmware v2.7.0.  WiFi Pineapple is using eth0 cabled to the LAN and connects to the C2 server over a stable private LAN with less than 2ms latency.  I'm running everything on my internal LAN for right now, just to test.  I've got PineAP running constantly, almost no modules installed (none of them are active anyway).

Here's what the my C2 looks like when the Pineapple disconnects:

SzTZGCm.png

VYpau9O.png

 

There is nothing interesting in the Pineapple itself by watching logread.

Here are my relevant Cloud C2 logs:

2020-04-28 12:28:07 Device 'Test Wifi Pineapple' has gone offline
2020-04-28 12:03:06 Device 'Test Wifi Pineapple' has started up
2020-04-28 11:28:49 Device 'Test Wifi Pineapple' has gone offline
2020-04-28 10:46:39 Device 'Test Wifi Pineapple' has started up
2020-04-28 09:42:04 Device 'Test Wifi Pineapple' has gone offline
2020-04-28 09:25:10 Device 'Test Wifi Pineapple' has started up
2020-04-27 17:01:00 Device 'Test Wifi Pineapple' has gone offline
2020-04-27 16:32:58 Device 'Test Wifi Pineapple' has started up

 

Share this post


Link to post
Share on other sites

What happens if you, after the pine disconnected, manually restart the CloudC2 Connection? maybe you see something in the output of the script...

Share this post


Link to post
Share on other sites

Nothing happens other than the Pine showing Offline in C2.  I found that if I manually issue a C2CONNECT from the Pine command line that it shows back up.  I ended up creating a cron job that runs every 10 minutes just to keep the stupid thing connected.

There are no useful messages anywhere in the Pineapple that I can find.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...