Jump to content

Recommended Posts

Firmware 2.7.0. I got my Nano up and running but I'm not getting any clients to connect.  I ran a recon, and added a spare laptop and my phone the PineAP filter along with my AP.  I created a filter and allowed only those two devices. I deauthed both devices. My phone re-connects to its regular AP, my laptop shows up under unassociated clients. Neither connect to my nano.  Just as a test, I removed all filters and deauthed my phone again (can't deauth the laptop from the GUI, but I did disconnect and reconnect the laptop's wifi from the laptop) but neither connect.

I'm still getting used to the interface, but I may have missed something.  I also downloaded a Deauth module with the same results.

Thanks for any input,

Mike

Share this post


Link to post
Share on other sites

Is the regular AP an open access point or does it require a password?

Share this post


Link to post
Share on other sites
Posted (edited)

Can you post a screenshot of your Pineapples "Networking" tab?

Omit any personal data.

Edited by Idk_Man

Share this post


Link to post
Share on other sites

I have it set to WPA2.  I reset everything and tried again. Now I can deauth, but my device (phone) sits in the associated clients area. If I turn off wifi and back on (on my phone) it goes back to my AP in the recon list.  

It looks like I can only insert an image from a URL.  I took the screen shots, but need to figure out how to post them.

 

Share this post


Link to post
Share on other sites

Route 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan
172.16.42.0     *               255.255.255.0   U     0      0        0 br-lan
Default RouteInterface                                 br-laneth0wlan0wlan0-1                             
 
Update Route

Access Points

AP Channel                                 1234567891011                             
 
Management SSID
 
Management PSK
 
Hide Management AP
Disable Management AP
Open SSID
 
Maximum Clients
 
Hide Open SSID
 
Update Access Points

OUI Lookup 

MAC Address
 
Lookup

WiFi Client Mode

Interface                                     wlan1mon                                 Scan
Note: Choosing wlan1 will interfere with PineAP.
 
 

MAC Addresses 

Interface                                 wlan0wlan0-1wlan1mon                             
 
Current MAC
 
New MAC


Set New MAC Set Random MAC
Note: Changing MAC addresses will restart the WiFi.

Advanced 

Hostname
Update
 
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:A9:94:61
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          inet6 addr: fd1a:49f:408d::1/60 Scope:Global
          inet6 addr: fe80::2c0:caff:fea9:9461/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5838 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8272 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2301555 (2.1 MiB)  TX bytes:3816238 (3.6 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:A9:94:61
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5807 errors:0 dropped:2 overruns:0 frame:0
          TX packets:8274 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2378409 (2.2 MiB)  TX bytes:3818996 (3.6 MiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:227 errors:0 dropped:0 overruns:0 frame:0
          TX packets:227 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15450 (15.0 KiB)  TX bytes:15450 (15.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:A9:88:A9
          inet6 addr: fe80::2c0:caff:fea9:88a9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:554 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4938 (4.8 KiB)  TX bytes:148580 (145.0 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:A9:88:A9
          inet6 addr: fe80::c0:caff:fea9:88a9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:537 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:146613 (143.1 KiB)

wlan1mon  Link encap:UNSPEC  HWaddr 00-C0-CA-A9-8E-A4-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:121581 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29896911 (28.5 MiB)  TX bytes:0 (0.0 B)

Share this post


Link to post
Share on other sites
Posted (edited)

When on your client device (your phone) which Nano access point are you trying to connect to?

Under the "Access Point" section in the Network page, there's two access points that you created when you did the initial setup for the Nano. One is under "Management SSID" and the other is "Open SSID". Make sure your client device (phone) is trying to connect to the "Open SSID" one.

Furthermore, looking at the pic you provided, it looks like your Nano doesn't have internet access. To see if I'm right or not, go to the "Dashboard" page and click on "Load Bulletins" button. Do you get an error message or do you see a bunch of text load?

Essentially, if your Nano doesn't have internet access, neither will the access points you're client device is trying to connect too.

Edited by Idk_Man

Share this post


Link to post
Share on other sites
19 hours ago, MGideon said:

I have it set to WPA2.  I reset everything and tried again. Now I can deauth, but my device (phone) sits in the associated clients area. If I turn off wifi and back on (on my phone) it goes back to my AP in the recon list.  

It looks like I can only insert an image from a URL.  I took the screen shots, but need to figure out how to post them.

 

Your devices aren't going to auto connect to the Pineapple if you are spoofing an access point that requires WPA2 encryption. WPA2 encryption is a mutual authentication. You devices are looking to exchange encryption information with the Pineapple (the spoofed SSID), but the Pineapple cannot provide that information. So your devices believe that it cannot be the SSID they are accustomed to connect to. The SSID you want to spoof is a public one that someone's phone may have used before. 

To get this to work for your devices, delete out your current AP/SSID from the programming of both devices. Reset your AP to use no authentication. Connect your devices to your AP. Now use the pineapple to spoof the SSID. Try your deauth attach now. Also remember that it helps if the Pineapple is closer to your devices than the AP is. If this doesn't work, just shut off your AP and see if they will connect to the pineapple automatically.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...