Jump to content

802.11 N Faster Than 802.11ac?


Recommended Posts

I've no idea whats happening here. I bough the AWUS036ACH wifi adapter. It sports the RealTek 8812AU chipset. anyways, like i said no idea, ill set the adapter to 802.11AC and prioritize 5Ghz band, run a internet speed test and get speeds like 16mbps down. Ill then set it to 802.11 a/n also prioritize 5Ghz band and get 66 mbps download. What the actual fuck? Whats even weirder is when i view my adapter through windows it shows 300mbps when using 802.11 n and like 620 for 802.11 AC. (Yes im aware my isp has bandwidth limits and i know i cant expect to achieve those speeds that my devices are capable of because of ISP bottle necking. And its not the router hardware limitation my router is a Archer A7 TPlink 1750AC.) Whats confusing me is why when i use 802.11 a/n im hauling ass. but when i use 802.11 AC im getting significantly less download speed? I dont know exactly where to look anymore. AC has just been SUPER finicky. It'll pop in a out of connectivity. ill have to disable and re-enable to get it to work, but even if i get it to maintain connection the speeds stay in that 16 mbps range. I dont understand i dont have enough knowledge to figure it out by myself please someone give me some guidance here. I've tried multiple drivers, with this chipset the ones from ALFA the ones from RealTek, the default windows ones, im just at a complete loss. it feels like something is bottle necking the 802.11AC protocol and i have no idea how to figure out where or why. And before someone suggests it im gonna hop on the router and see if i can update the firmware or something. but if anyone has any other suggestions or ideas please let me know. thanks


Link to comment
Share on other sites

I'd Just like to add that I've upgraded my router firmware and have noticed no particular change in performance. I've tried changing the protocols on the card and disabling the LDPC (low density parity check) function since its optional with 802.11AC protocol, as well has the STBC(space time block coding) functionality since it too is optional for 802.11 AC to work, i thought maybe these optional functionalities were messing with the adapter somehow. But no noticeable improvement. At the moment I'm experimenting with my USB ports, I've updated my USB 3.1 port drivers and have tried switching between USB 2.0 and USB 3.0, since this adapter seems to drop connection randomly I think it may be a USB issue of some kind. My next and worse case scenario guess is that the drivers for this adapter are utter garbage. This is a 60-70$ adapter and by no means is cheap. I really hope i didn't shell out that kind of money on this adapter to just be a piece of junk. As of right now id say stay the hell away from the AWUS036ACH if youre using it on Windows 10.

Will continue trying to diagnose these issues. Anyone who has the same adapter or similar issues with other adapters feel free to drop any information you may have found.


Link to comment
Share on other sites

  • 3 weeks later...

Alright so I've continued messing with this adapter, there is something really odd that happens. When my channel is selected on a 5g channel like 44 for example. my adapter will show theoretical speeds about 565 mbps, however when i change the channel to channel 165 the max it will go is 130mbps. I've no idea why this happens, if anyone has any insight please let me know.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...